Quadro M4000 doesn't work on RHEL7

hi All,

I’m not able to have 3d vision on my RHEL7.
[b]
kernel: 3.10.0-514.el7.x86_64 #1 SMP Wed Oct 19 11:24:13 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux

Driver: version 375.20 (buildmeister@swio-display-x86-rhel47-06) Tue Nov 15 17:48:39 PST 2016

Card: Quadro M4000

/etc/X11/xorg.conf

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 375.20 (buildmeister@swio-display-x86-rhel47-06) Tue Nov 15 17:48:39 PST 2016

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 375.20 (buildmeister@swio-display-x86-rhel47-06) Tue Nov 15 17:49:44 PST 2016

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
FontPath “/usr/share/fonts/default/Type1”
EndSection

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/input/mice"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “BenQ XL2720Z”
HorizSync 30.0 - 160.0
VertRefresh 56.0 - 144.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Quadro M4000”
EndSection

Section “Screen”

Removed Option “nvidiaXineramaInfoOrder” “DFP-1”

Removed Option “metamodes” “nvidia-auto-select +0+0”

Removed Option “metamodes” “1920x1080_144 +0+0”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-7"
Option         "metamodes" "1920x1080_120 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection

Section “Extensions”
Option “Composite” “disable”
EndSection

[/b]

X launches ok and has resolution of 1920X1080 as suggested in the xorg.conf file.

However the nvidia-settings gui doesn’t give me an option to do 120Hz which is required for 3d vision. When I force stereo 10 in the xorg.conf file. X fails to launch. The error as seen from /va/log is reported below.

[ 44.055] (EE) NVIDIA(GPU-0): Unable to add conservative default mode “nvidia-auto-select”.
[ 44.055] (EE) NVIDIA(GPU-0): Unable to add “nvidia-auto-select” mode to ModePool.
[ 44.055] (WW) NVIDIA(0): No valid modes for “nvidia-auto-select+0+0”; removing.
[ 44.055] (WW) NVIDIA(0):
[ 44.055] (WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
[ 44.055] (WW) NVIDIA(0): “nvidia-auto-select”.
[ 44.055] (WW) NVIDIA(0):
[ 44.055] (WW) NVIDIA(0): No valid modes for “DFP-1:nvidia-auto-select”; removing.
[ 44.055] (EE) NVIDIA(0): Unable to use default mode “nvidia-auto-select”.
[ 44.055] (EE) NVIDIA(0): Failing initialization of X screen 0

I’m having trouble to understand how it is trying to get the mode auto-select 'ed when there is no such option in the xorg.conf?

Please help. This is a showstopper.

Thanks
Ramesh