Quectel RM500q and Rm510q both not getting detected on AetinaAn810 Carrier Board for Xavier NX

I’m using Aetina An810 carrier board for Xavier NX with Quectel 5G RM500 and RM510q on JF5 m.2 port, Can’t detect the 5G module after “lspci”. Installed drivers on carrier board, reflashed firmware of Quectel RM510 series board, and still no detection.

Would like to know the ways to detect the module on the carrier board and what are the probable solutions for this. Are the other m.2 ports any use for the module?

We haven’t tested that 5G module, not sure why can’t detect it with “lspci”.
You may contact with Aetine for the support to get at least the device got scaned by “lspci”.

Alright, on Quectel’s website somehow it’s mentioned about the compatibility of RM50xq series with jetson platform which includes the Xavier NX, although the dimensions of the 5G module is also not matching with the screw hole of m.2 b key.

And now Nvidia haven’t even tested the quectel modules.

Strange. But yeah let me contact Aetina for the same. The link is below.

Can you please provide the list of 5G modules which have already been tried and tested with Nvidia Jetson Platforms?

We don’t have the list, customer can test by themselves.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.