Question about error report when running python.sh

When I try to follow the tutorial to generate synthetic data, I run these codes: ./python.sh tools/composer/src/main.py --input */parameters/tutorial.yaml --output */dataset/tutorial_1 --mount ~/composer-workspace --num-scenes 10
Then I get error report as shown in picture above. Could someone help me figure out what goes wrong?

Hi there,

to narrow down the issue can you write the GPU, OS and Isaac Sim version you are running.
If you start Isaac Sim with the editor, do you get any similar errors?

Best,
Andrei

Hello, I tried to reinstall Isaac Sim and the problem is solved. However, I have encountered another problem when I am trying to generate synthetic data through Replicator Composer.

After I input this command in the terminal:
./python.sh tools/composer/src/main.py --input */parameters/tutorial.yaml --output */dataset/tutorial_1 --mount ~/composer-workspace --num-scenes 10

Error message:

I am using Isaac Sim 2022.1.1 on Ubuntu 20.04.5 LTS. The GPU is NVIDIA Corporation TU102 [GeForce RTX 2080 Ti Rev.A]. Also I have another problem: after I pressed launch button on Omniverse Launcher, the Isaac Sim App selector popped up but disappeared immediately. I cannot access the UI of Isaac Sim App selector. May I know how to generate error reports or logs so that I can tell what’s going wrong?

You can run it with ./isaac-sim.sh instead of ./python.sh.

Could you also send the output of the nvidia-smi command to make sure you have the right drivers installed?

1 Like

Here is the output of nvidia-smi command:

I try to use isaac-sim instead of python and get this error report:

I think I did not set up the nucleus properly. But I am not sure what I should do. Could you help me?

I follow this instruction to set up the Nucleus: Known Issue: Error checking Isaac Sim Assets

This screenshot shows how I set it:

However, when I try to run this command: ./isaac-sim.sh tools/composer/src/main.py --input */parameters/tutorial.yaml --output */dataset/tutorial_1 --mount ~/composer-workspace --num-scenes 10

I still cannot get expected result as shown in this tutorial: Isaac Sim: Generating Synthetic Data using Replicator Composer - YouTube
Instead, I only get a empty new stage which, same as the default stage when I open Isaac Sim via App Selector directly. Is this tutorial out of date? Any new tutorials available? To be honest It is really hard to find updated tutorial videos for Isaac Sim

I think I managed to fix the problem caused by nucleus server. However now I have new error report:

Is this caused by unstable connection to internet? And may I know how should I increase the timeout if that is the reason? since the speed of wifi I am using is quite slow.


It seems that the software keeps retrying to load materials

Btw, what’s the difference between using python.sh and using Isaac-sim? I thought in the tutorial about generating synthetic data with replicator composer (5. Replicator Composer — Omniverse Robotics documentation) they use python.sh. Will it produce any difference?

This is what I get when I run it using python.sh instead. It seems that it needs the original NIDIA/Assets mount path.