Question about mystery "_" under SDDM in top left corner

Did anyone experienced that, using nvidia card in X config (xorg.conf) in /etc/X11/ ending in that mystery _ , i dont know its a bug in SDDM itself or in nvidia driver in general?.
Also, driver proposes to edit xorg.conf file by itself (nvidia-xconfig).

#Section "Device"
#    Identifier     "Device0"
#    Driver         "nvidia"
#    VendorName     "NVIDIA Corporation"
#    BusID          "PCI:1:0:0"
#EndSection
Section "Device"
    Identifier          "Device2"
    Driver              "amdgpu"
    VendorName          "AMD"
    BusID               "PCI:6:0:0"
EndSection


mystery _ (youtube link)

lsd@Crawler-E25:~$ lspci | grep -i --color 'vga\|3d\|2d'
01:00.0 VGA compatible controller: NVIDIA Corporation GA107M [GeForce RTX 3050 Mobile] (rev a1)
06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne [Radeon Vega Series / Radeon Vega Mobile Series] (rev c6)
lsd@Crawler-E25:~$ 

rtx 3050m 550.54.14 (newest to date)
side thread

You’re on a hybrid graphics notebook, the internal screen being driven by the amd gpu. If you create an xorg.conf with an nvidia “Device” section, the internal screen will be excluded from the Xserver. No bug, expected behaviour. https://wiki.archlinux.org/title/NVIDIA_Optimus

Trying to force nvidia as main card to use, but still is not used. from this advice

lsd@Crawler-E25:~$ cat /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf
Section "OutputClass"
    Identifier "AMD-KARTA"
    MatchDriver "amdgpu"
    Driver "modesetting"
EndSection

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "PrimaryGPU" "yes"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"

Sun Mar  3 22:48:48 2024       
+-----------------------------------------------------------------------------------------+
| NVIDIA-SMI 550.54.14              Driver Version: 550.54.14      CUDA Version: 12.4     |
|-----------------------------------------+------------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id          Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |           Memory-Usage | GPU-Util  Compute M. |
|                                         |                        |               MIG M. |
|=========================================+========================+======================|
|   0  NVIDIA GeForce RTX 3050 ...    Off |   00000000:01:00.0 Off |                  N/A |
| N/A   48C    P0             N/A /   60W |       1MiB /   4096MiB |      0%      Default |
|                                         |                        |                  N/A |
+-----------------------------------------+------------------------+----------------------+
                                                                                         
+-----------------------------------------------------------------------------------------+
| Processes:                                                                              |
|  GPU   GI   CI        PID   Type   Process name                              GPU Memory |
|        ID   ID                                                               Usage      |
|=========================================================================================|
|  No running processes found                                                             |
+-----------------------------------------------------------------------------------------+

still 1 precent card usage and 1MB VBRAM, what im doing wrong?
Kubuntu 23.10
SDDM starting normally
NOTE: i cant enable/disable ANY card in my BIOS, is tottaly stipped/hidden optioned (Insyde corp)

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log (3.0 MB)
V2 (installed acpidump)

Please delete
/etc/X11/xorg.conf
and
/etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf

1 Like

I always run sddm on Wayland session so thats how my actual nvidia-smi looks now,

Secondly it started up somehow with missing those files :O

lsd@Crawler-E25:/etc/X11$ nvidia-smi 
Wed Mar  6 10:43:49 2024       
+-----------------------------------------------------------------------------------------+
| NVIDIA-SMI 550.54.14              Driver Version: 550.54.14      CUDA Version: 12.4     |
|-----------------------------------------+------------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id          Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |           Memory-Usage | GPU-Util  Compute M. |
|                                         |                        |               MIG M. |
|=========================================+========================+======================|
|   0  NVIDIA GeForce RTX 3050 ...    Off |   00000000:01:00.0 Off |                  N/A |
| N/A   37C    P0             N/A /   60W |       7MiB /   4096MiB |      0%      Default |
|                                         |                        |                  N/A |
+-----------------------------------------+------------------------+----------------------+
                                                                                         
+-----------------------------------------------------------------------------------------+
| Processes:                                                                              |
|  GPU   GI   CI        PID   Type   Process name                              GPU Memory |
|        ID   ID                                                               Usage      |
|=========================================================================================|
|    0   N/A  N/A      1266      G   /usr/lib/xorg/Xorg                              4MiB |
+-----------------------------------------------------------------------------------------+
lsd@Crawler-E25:/etc/X11$ 

lsd@Crawler-E25:~$ cd /etc/X11/
lsd@Crawler-E25:/etc/X11$ ls
app-defaults  default-display-manager  rgb.txt  xkb          Xreset    Xresources  Xsession.d        xsm         Xwrapper.config
cursors       fonts                    xinit    xorg.conf.d  Xreset.d  Xsession    Xsession.options  XvMCConfig
lsd@Crawler-E25:/etc/X11$ cat xorg.conf.d/
cat: xorg.conf.d/: Is a directory
lsd@Crawler-E25:/etc/X11$ cd xorg.conf.d/
lsd@Crawler-E25:/etc/X11/xorg.conf.d$ ls
lsd@Crawler-E25:/etc/X11/xorg.conf.d$ 



I should leave that how it is now?
Of course smi report is not valid since i have lots more programs opened than just xorg.

The nvidia gpu is now in offload mode, per default the AMD gpu is used. If you right-click on an application icon, there should be an entry “run on discrete gpu”. This will start applications using the nvidia gpu.

theres no such option in my kde

Operating System: Kubuntu 23.10
KDE Plasma Version: 5.27.8
KDE Frameworks Version: 5.110.0
Qt Version: 5.15.10
Kernel Version: 6.5.0-21-generic (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 5600H with Radeon Graphics
Memory: 22.8 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: MEDION
Product Name: Crawler E25
System Version: Not Applicable

but its not related to this case, i run game from steam with that extra command __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia %command% and it works, it starts using nvidia

alone

__NV_PRIME_RENDER_OFFLOAD=1
in steam doesnt do anything

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.