Question about update camera firmware on Nano with Jetpack 5.1.3

Hi, I was using firmware from AGX Orin camera issues - #23 by JerryChang and instructions from Request debug RTCPU image for JP5.1.1 - #5 by JerryChang

But I got an error in the flash step. Here is what I did.

On the laptop I used to install firmware on jetson, I found this path containing all tools:

~/nvidia/nvidia_sdk/JetPack_5.1.3_Linux_JETSON_ORIN_NANO_TARGETS/Linux_for_Tegra

So within this path, I run

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" -p --showlogs --network usb0 p3768-0000+p3767-0000-nvme internal

I changed the parameter to “p3768-0000+p3767-0000-nvme” because I was using nano

Then by running

ls tools/kernel_flash/images/internal/

I can find the camera-rtcpu-t234-rce_sigheader.img.encrypt

Next I unziped 7z file and copied camera-rtcpu-t234-rce.img to bootloader and run

sudo ./flash.sh --no-flash -r -k A_rce-fw p3768-0000+p3767-0000-nvme mmcblk0p1

And I can see *** camera-rtcpu-t234-rce.img has been signed successfully. ***

Then I copied the encrypted file by

sudo cp /home/sh/nvidia/nvidia_sdk/JetPack_5.1.3_Linux_JETSON_ORIN_NANO_TARGETS/Linux_for_Tegra/bootloader/camera-rtcpu-t234-rce_sigheader.img.encrypt tools/kernel_flash/images/internal/camera-rtcpu-t234-rce_sigheader.img.encrypt

In the last step, I shut jetson down, hold recovery button and press power button. Connect a usb cable to recovery port. Then I run

sudo ./tools/kernel_flash/l4t_initrd_flash.sh -k A_rce-fw --flash-only --showlogs

But I got error like:
[ 0.1505 ] BL: version 1.4.0.1-t234-54845784-08e631ca last_boot_error: 0
[ 0.3086 ] Sending bct_mem
[ 0.3444 ] Sending blob
[ 0.4201 ] ERROR: might be timeout in USB write.
Error: Return value 3
Command tegrarcm_v2 --instance 1-6 --chip 0x23 0 --pollbl --download bct_mem mem_rcm_sigheader.bct.encrypt --download blob blob.bin
Cleaning up…

What did I do wrong?

hello Deqing_S,

it sometime the USB communication issue of flashing failure, had you tried flash to Orin Nano before?

I used the same cable and laptop to setup 5.1.3 on nano on a new nvme drive. There was no error at all.

I tried to restart in recovery again but I got the same error 3.

hello Deqing_S,

please see-also Topic 237459. please give it a try with USB autosuspend disabled,
for instance,
sudo -s
echo -1 > /sys/module/usbcore/parameters/autosuspend

No I tried the command to write to /sys/module/usbcore/parameters/autosuspend
And I still get error 3
After reboot the laptop I still get the error 3

hello Deqing_S,

please give a try with below to flash individual partitions by initrd.
for instance,

$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh \
  --external-device nvme0n1p1 \
  -c ./tools/kernel_flash/flash_l4t_external.xml \
  -k A_rce-fw --external-only jetson-orin-nano-devkit mmcblk0p1