Question: Is it possible to use SDK manager to download CUDA libraries onto a USB?


As the title suggests, is it possible to use a boot from USB Jetson Nano with software packages installed from Jetpack? I just don’t have enough space with the things installed from Jetpack.
At first, I used my jetson and got some basic computer vision code running on it :D .
However, to use more advanced CUDA features I apparently needed to reflash my jetson which I have done.
Sadly, I am now stuck with the original 16 GB of EMMC storage. I had a really neat U-disk I booted from which did not have any of these storage problems.

I did end up being able to download the fresh flash of CUDA libraries from SDK manager and jetpack, but now the jetson does not even have space to download python on VS code. I tried deleting all the random stuff onboard and there is plain just no space avaliable. Around 200mB. Its a pretty dire situation.

What have others done to do CUDA stuff with a USB boot. Is it possible to just download just a few things with SDK manager?

I have tried googling but I have not seen any guides on this specifically or other questions like this.
I hope someone can help me or provide some tips/advice.

Over the past month I have been trying to get my Jetson Nano to work.
Ideally, I want to use CUDA code to run basic OPENCV stuff in real time.
I am not an intellectual, but I will keep trying to do this.

Thank you .


Here is the TX2 board, do you use Jetson Nano or Jetson TX2?


Hello. I use the Jetson Nano board.

In short, my question is how I can install applications on a USB-drive if my jetson’s local memory is full of necessary pre - installed features I cannot remove.

Any tips, guides, or words to constrain searches?


1 Like


Sorry for the late update.
Please check below topic for the information:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.