Question towards JetPack installing on PC

Hi, Thanks in advance.

I would like to install the JetPack on my host PC and use USB to install the JetPack on my JetsonTX1.

When I run this:./JetPack-L4T-3.1-linux-x64.run
Creating directory _installer
Verifying archive integrity… All good.
Uncompressing JetPack 100% Extraction failed.
Terminated

When I run this:sudo ./JetPack-L4T-3.1-linux-x64.run
Creating directory _installer
Verifying archive integrity… All good.
Uncompressing JetPack 100%
And there is a pop-up said: Please run Please run JetPack as a non-elevated user: when root access is needed, the installer will prompt you.

I found a similar topic here, but it seems not solve my question.https://devtalk.nvidia.com/default/topic/1019641/jetson-tx1/jetpack-3-1-mdash-l4t-r28-1-released-for-jetson-tx1-tx2/

I guess is because the root? I log in as a normal user(Because this is school’s computer).

Please help me about this, I appreciate your time! :)

You need to completely remove all of the install directory (be careful…“sudo rm -Rf /where/ever/it/is/ran/JetPack/here”). Then you need to make sure the directory you are installing from is not owned by root:

ls -ld .

If the directory you are running from is owned by root, then either use a different directory, or change ownership back to you with chown (“man chown”).

Only then should you run JetPack to start an install…this will unpack into a directory owned by your user and content will correctly be non-root ID where intended. When root ID is needed your password will be used to automatically sudo (root ownership is used to unpack sample rootfs and to apply_binaries.sh, but not for the rest of the install…additionally certain loopback-related commands will use sudo, but many commands do not use sudo).

The trouble is that when you go to install and some parts of install are intended to not be root ownership JetPack cannot complete the operation.

Hi linuxdev, after I use ls-ld, I found this: drwxrwxr-x 3 ubuntu ubuntu 4096 Nov 7 14:58
So this means this is not owned by root is owned by ubuntu, right?

That is correct. User ubuntu, and any user within group ubuntu (and there are none unless you added this) can read, write, or execute within that directory. There should be nothing stopping user ubuntu from unpacking files there. Do you still have errors?

Exceptions:

  • A file system which is full would reject writing.
  • A file system which is mounted read-only would reject writing even if permissions say writing is possible.
  • Some file systems (such as ISO-9660 of a CD/DVD) do not have a write ability...these are all read-only.
  • There could be an exception if SElinux is set to enforcing and rules have been set up such that ubuntu does not have a role for that location. An example might be in "/var/www/html" web server for cases where ubuntu would need to have the correct role...but this is extremely unlikely, you'd probably know if you had SElinux enabled as enforcing. Even if you did have this enabled this would still be ok to unpack as user ubuntu in any subdirectory of ubuntu's home directory...a user always has a role as self.

Hi, I found out that I need to create a folder in the /Home, then it works fine.

Regards and thanks!

It is recommended that you check the running path of JetPack and whether it is in the same folder with the default document path of JetPack.