R32.2.1 audio out


In my platform, Open the “System Settings” => Sound settings

I have an RT5640, it is enumerated as an “Analog Output” card. And RT5640 is in charge of the line-out audio.

Also TX1 connects to an HDMI monitor with speaker. So I had another device “HDMI/DisplayPort”.


  1. Play music file and select the audio-out device as “HDMI/DisplayPort”.
  2. Check the sound is from the monitor speaker.
  3. Turn off TX1 via Ubuntu
  4. Turn on the TX1 and play music file again.
  5. Check the sound is from the “HDMI/DisplayPort”
  6. Check the “System settings”=>“Sound”

==> the highlighted item is “Analog audio”

Can somebody help?

Hi HelloKittyWorld,

Please check if can gain some idea from at Troubleshooting section from:https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%2520Linux%2520Driver%2520Package%2520Development%2520Guide%2Fasoc_driver.html%23wwpID0E0SH0HA