R32.3.1 tx2-4g pwm-fan

was getting vdd-fan disabling in dmesg, changed device tree and now that message is gone.

jtop says that the fan is controlled by “system”

no /sys/kernel/debug/tegra_fan files.

How do I test/know if the fan is working correctly.

Terry

hello terrysu50z,

you should execute jetson_clocks.sh, it’ll spin the fan at maximum speed.
note, starting with Release 32.4, jetson_clocks no longer sets maximum fan speed by default. If you prefer the old behavior, use the --fan option.
thanks

Please describe the old behavior.

Please give more info about --fan, I ran
jetson_clocks -h
Maximize jetson performance by setting static max frequency to CPU, GPU and EMC clocks.
Usage:
jetson_clocks.sh [options]
options,
–show display current settings
–store [file] store current settings to a file (default: ${HOME}/l4t_dfs.conf)
–restore [file] restore saved settings from a file (default: ${HOME}/l4t_dfs.conf)
run jetson_clocks.sh without any option to set static max frequency to CPU, GPU and EMC clocks.

no --fan parameter documentation.

How do I make the system control the fan based on temp.

Thanks,
Terry

hello terrysu50z,

the --fan options is not included in the R32.3.1 release.
when you execute jetson_clocks, the fan is spinning at max speed by default.

So how do I get the fan to be controlled by temp?

Terry

hello terrysu50z,

please check developer guide, Thermal Cooling.
there’s device tree configuration for the thermal zones, that’s mapping to different PWM values for controlling fan speed.
please also refer to kernel documentation as see-also,
i.e. $L4T_Sources/r32.3.1/Linux_for_Tegra/source/public/kernel/kernel-4.9/Documentation/devicetree/bindings/thermal/thermal.txt

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.