Random crash with 375.26 when launching the game Recursed

I have a GeForce GTX 750 Ti, using the 375.26 drivers on Ubuntu.

This problem occurs with the game Recursed, available on Steam:
http://store.steampowered.com/app/497780/

Sometimes when I launch the game, I get this crash in libnvidia-glcore:

Sometimes it crashes on the first attempt, sometimes on the ~20th.
I also crashed it with a different window manager: Metacity - in which case the crash causes the computer to freeze.

The problem also happens with an earlier version of the driver 367.57, with these log messages:

I run many games on this machine, and never had this issue. The issue doesn’t happen on Windows running on the same machine.
The game’s developer has not received any other similar reports, and has also tested it on Linux.
nvidia-bug-report.log.gz (205 KB)

Is the game crashing, or the window manager?

Either way, can you capture an apitrace that reproduces the problem more readily?

Thanks

I am not sure if it’s the window manager, or X is crashing.

When I run Metacity in a tty using valgrind, launching the game boots me out to the graphical login screen (instead of freezing). This causes all graphical programs to close, but I think the game doesn’t crash (see below).

From metacity I only get this error:

(attaching apitrace output).

When I run it with compiz/unity in the same way (through a tty), I haven’t been able to reproduce the problem. The most that happens is sometimes on launch all the windows seem to close, then open again, with the game still running.

Any ideas on how to diagnose this further? At this point I’m not even sure it’s an nvidia hardware/driver problem.
recursed.x64.5.trace.gz (596 KB)

We are tracking this issue under bug Bug 200269622

Hi salty-horse, Is any earlier nvidia driver help to fix this crashing issue? What desktop environment you are running Unity, Gnome, Kde or else? Please provide as much as information that will help us to reproduce this issue here to investigate further.

We are not able to repro using below config:

Config:- ( Dell precession tower 7910 + GTX 750 Ti + Ubuntu 16.10 + desktop environment ( ubuntu default , plasma ) + Driver 375.26 + Game Recursed )

Repro steps:-
Installed driver on ubuntu 16.10
download and install game recursed.
On terminal launch the game

test@test-Precision-T7610:~/.steam/steam/steamapps/common/Recursed$ sudo ./recursed.sh

Could not observe crash on launching the game, i have attempted try on launching and closing the game with 20 times.
used desktop environment as plasma, ubuntu.
Also tested with driver 367.57 and 375.26 no repro

Query:-
What desktop environment you are running Unity, Gnome, Kde or else?
How did you launch the GUI session " i mean did they used metacity --replace" ?
does it repro normal with ubuntu environment such has plasma, unity ?
can you please share the video of the repro steps ? it will help us to understand more.

Hi Sandip, and thanks for testing!

I only tested the versions listed in my original post (367.57, 375.26), and both exhibited the problem.

I am using Gnome and Metacity (which Ubuntu’s login manager calls “Gnome Classic”, or something to that effect).

During my testing before, running apitrace, I noticed that it doesn’t freeze when I use “metacity --replace”. I could recover at that point by running “DISPLAY=:0.0 metacity --replace” from a tty.

I will share a video of the Metacity freeze in the next few days.

Hi salty-horse,
WE are not able to repro the issue as customer reported.

we observed during launch and closing the game continuously, would automatically goes to black screen and then revert back to login screen.

below are the issue what i am getting in dmesg logs.
2290.707222] nvidia-modeset: Allocated GPU:0 (GPU-ca9102dd-5d09-111e-c9f3-b8285801d71c) @ PCI:0000:05:00.0
[ 2477.729331] QXcbEventReader[32204]: segfault at 7fd3e1f1f299 ip 00007fd3e1f1f299 sp 00007fd3df394d20 error 14 in 0c9eb80ebd1c36541ebe2852d3bb0c49-le64.cache-6[7fd3e1fe8000+1000]
[ 2484.452672] nvidia-modeset: Freed GPU:0 (GPU-ca9102dd-5d09-111e-c9f3-b8285801d71c) @ PCI:0000:05:00.0
[ 2484.965073] nvidia-modeset: Allocated GPU:0 (GPU-ca9102dd-5d09-111e-c9f3-b8285801d71c) @ PCI:0000:05:00.0

we will wait for the video

Please help to provide below info:

  • steps of a repro video from the customer?
  • Could you please share my repro steps attempted to customer to do verify if we miss something?
  • How frequently the crash happen, is it consistent ? and in which desktop environment it causes more frequent crash?
  • the exact repro steps in step format?
  • Any multi-monitor setup required for this to repro? as i dont see xorg.conf been generated on bug-report " Run sudo nvidia-xconfig on terminal to generate the xorg.conf and retry repro"?
  • In Kernel Parameter i see “video=uvesafb:mode_option=1024x768-24”, did you configured the uvesafb? can you please try removing this option, reboot and try repro?
  • Did you performed any customized kernel or upgraded, if yes, how?

Sorry for the delay.

I have tried running the game several times with the same configuration that caused the freezes, and the most it does is boot me back into the login screen. It no longer freezes the computer.

Metacity now fails with:

Here are videos showing the new (uninteresting) behavior in Metacity (which used to freeze):
https://www.youtube.com/watch?v=iPzGCFuy2Zk
https://www.youtube.com/watch?v=YtdQQy9EgQM

I did not update the Nvidia driver or metacity. I did upgrade the kernel from Ubuntu’s 4.8.0-32 to 4.8.0-34

I will try removing the uvesafb setting (which I do not remember if I add myself, or if it’s a default Ubuntu setting), and try with the old kernel version.

To answer your other questions:

  • The steps involved are just launching the game from Steam or the command line (with the recursed.sh script you already used above).
  • I use a single monitor, single X client.
  • It takes anywhere from 1 to 20 attempts to crash it. Unity and Metacity crashes feel comparable in frequency.

All evidence points to this being a window manager bug. This can be closed.

Sorry for the bother, and thanks for assisting!