Random Xid 61 and Xorg lock-up

I am also willing to offer up ssh access when it happens again if someone might find that helpful. Would just need to know who to contact.

My computer has just entered this state. The link below is to my nvidia-bug-report.log.gz


I can leave my computer in this state for the rest of the day. Anyone from NVIDIA, please let me know if you would like ssh access to help diagnose this issue. I will probably have to restart this computer by tomorrow.

We had earlier took remote session for one of the user but it was not much of significance.
I have been trying lately to reproduce issue locally on MSI X570 but no luck so far.
Most of the users have issue on Gigabyte motherboard but unfortunately due to covid-19, I can not access it at this moment.
I have been trying and syncing with other nvidia premises members to get hold of gigabyte m/b.
Hopefully I will be able to get in coming week and then try to reproduce issue locally.

Hey Amrits,

Most of the users have issue on Gigabyte motherboard but unfortunately due to covid-19, I can not access it at this moment.

In the UK, there has been steady stock of various Gigabyte x570 motherboards on Amazon and Ebuyer with next day delivery. A few £100 seems like a drop in the ocean to help diagnose this?

Where are you based? I’m happy to help source one.

1 Like

I am also experiencing the same issues.

  • AMD 3950X
  • GeForce GTX 1660 Super
  • G.SKILL Ripjaws V Series 64GB
  • Ubuntu 18.04
  • Nvidia Drivers 440.82

The problem for me seems to occur more frequently if I have Steam up and running but it has also happened plenty of times without Steam open. Sometimes it occurs within 1-2 days and others can occur after 7+ days of uptime.

Hi! I am in “Xid issue” club too.

  • EVGA GTX 1660 Super
  • AMD Ryzen 5 3600
  • MSI B450m pro m2
  • Ubuntu 20.04
  • Drivers 440.64

Hi admin8cqme,

I am based in Pune (India) and my peers are in Santa Clara where delivery in not available currently so soon.
We are trying our best to find Gigabyte board internally as the MSI and Asus X570 boards we ran on did not exhibit any issues.

@amrits is it possible to see a list of the exact hardware configurations you have tried (eg cpu, mobo, ram, gpu, display)?

Looks like on Windows, this is known as “nvlddmkm event 14” so not a Linux exclusive bug.
Anyone ever tried if disabling SMT in bios has influence on this?

1 Like


  • I have been experiencing xid 61 approx 2-3 times a week for a few months now.
  • Was stable under Windows.
  • Apologies if some info below is duplicated from above; I have only skimmed this thread.

Description of crash

I’m sure this has been noted before, but the stuttering only occurs in frames that need rendering. (My use of the word “rendering” is probably technically inaccurate. What I am trying to convey is the amount of processing power required to draw to the screen.)

My setup is incredibly light; I use ~vanilla xmonad as a WM and I do not have a desktop environment. I typically have two windows side-by-side: a terminal and a web browser.

After the crash occurs I am able to move the mouse freely over the terminal window with no stuttering. However as soon as I move it over the rendered window the stuttering starts again. Bringing the mouse to a stop for several seconds over the terminal will stop the stuttering (until I move it over chromium again).

When does the crash occur?

The more I see this crash, the more I think it’s related to the graphics card not rendering anything. Ie it is more likely to crash if you spend time without anything updating on the screen.

My most common crash condition is when I leave the computer for 30-60mins. I do not have a lock screen nor do I suspend the computer. If I have a static webpage on the screen for this length of time, it might crash. It has not crashed while, say, playing a video for 30mins (something I do far more often than step away from my PC for 30mins!!). If you want to replicate, my best bet would be replicating my setup described above, and then leave it for an hour, but this is not a foolproof method.

My second most common crash condition is when I have a terminal fullscreen and chromium in another workspace. Upon switching to the chromium workspace, I will enter the crash. This adds weight to the idea that it’s somehow related to the card not needing to render anything.

How can you exit the crashed state?

I am only able to exit the crash by restarting my computer. Exiting X and returning to tty takes upwards of 30s. When tty does eventually load, any attempt to restart X leads to a hang which requires a hard power-off.


  • AMD Ryzen 5 3600X
  • Gigabyte X570 I AORUS Pro WIFI (bios version F12e)
  • Corsair VENGEANCE LPX 64GB DDR4 DRAM 3600MHz C18
  • ASUS AORUS GeForce RTX 2080 Ti XTREME 11G
  • Arch Linux v5.6.8-arch1-1
  • NVIDIA drivers v440.82
  • X.Org X Server 1.20.8
  • X Protocol Version 11, Revision 0
  • 1x DisplayPort v1.4 monitor


nvidia-bug-report.log (729.0 KB) nvidia-bug-report2.log (531.4 KB)

I’ve been encountering Xid 61 for months now. It has become unbearable now, starting to happen every couple of hours and has made my system almost unusable. This happens both in Windows 10 & Linux.

  • Gigabyte geforce gtx 1660
  • Amd Ryzen 5 3600
  • Asrock B450 Steel Legend
  • Debian (Debian 5.6.7-1 (2020-04-29) x86_64 GNU/Linux
  • NVIDIA drivers v440.82-1

@amrits is it possible to see a list of the exact hardware configurations you have tried (eg cpu, mobo, ram, gpu, display)?

I have tried lately on below configuration setup -
MPG X570 GAMING EDGE WIFI (MS-7C37) + AMD Ryzen 7 3700X 8-Core Processor + Driver 430.34 + GeForce RTX 2070 + 1 display with 4k / 2k Resolution
Asus X570 + AMD Ryzen 7 3700X 8-Core Processor + Driver 430.34 + GeForce RTX 2070 + 2 Displays with 1920 x 1080
MSI X570 + Ryzen 3700x + Ubuntu 19.10 + NV Driver 435.21 setup + 2 Displays with 1920 x 1080

Also tried on other configuartion apart from X570 m/b

Alienware Area-51 R6 + Ubuntu 18.04.4 LTS + 5.3.0-46-generic + GeForce RTX 2070 + Driver 430.34
Precision T7610 + Ubuntu 18.04.4 + kernel 5.5.6 + GeForce RTX 2080 + Driver 430.34

FYI: AMD has released AGESA which might be fixing this, so please keep an eye open for bios updates (only MSI MAX models have that so far).

@amrits Is your card a Super? Seems to be repoing more with those.

Hi! I’ve updated b450m pro-m2 max BIOS to 7B84vA6 version(includes AGESA
The problem hasn’t gone.

@yetibrain thanks for checking, did you also try if disabling smt helps?

No, but i just disabled, will be watching

I’m also getting Xid 61 on:

  • mobo: Asus x570 TUF Gaming Plus (WIFI) bios 1407
  • cpu: 3700x
  • gpu: msi rtx 2070 super
  • driver: 440.82
  • os: pop os 20.04 lts (aka ubuntu)
  • de: gnome
  • wm: xmonad (very lightweight)
  • running apps: alacritty (gpu accelerated terminal), chrome, emacs

I get this issue around twice a week in linux, but I don’t in windows 10 on the latest drivers there.

When this issue isn’t happening, nvidia-smi says that xorg is using 1gb of vram, which seems very very excessive (i’m just using xmonad with a few terminals running). I don’t know if it’s related.

When the issue happens, like others have reported, nvidia-smi basically hangs and can’t query some things like temp and vram usage. Xorg is pegged at 100% cpu usage and chrome is also pegged. ssh works but I basically just have to reboot.

I have tried that out as well. Setting processor.max_cstate=1 does not work, the error still occurs from time to time.

I will be trying with 2070 super card today or this weekend with MSI X570 and share my results by early starting of week.
As we know there is not a single method to hit with Xid 61 issue, if anyone is able to recreate it with same steps consistently, please provide the same.