Rare blackouts / blinks with G-Sync

Sorry, for posting this in dev forum, but i don’t know where to go more…

I’ve got laptop:

Acer Predator G9-593
Intel Core i7-6700HQ (2.6Ghz/3.5Ghz) (https://goo.gl/dehk14)
Nvidia GeForce GTX 1070 (8Gb GDDR5) (https://goo.gl/z2aEFL)
15.6inch 1920x1080 (G-Sync) (IPS)
16Gb DDR4-2400 / PC4-19200 (2x ACR24D4S7S8MB-8)
Windows 10 x64
Nvidia driver - 378.49

And one strange issue. Sometimes, in games, my screen will just blink/blackout, for less then a second. Happens extremely rare, in totally random situations, and only when g-sync is enabled.

One example: yesterday i was plaing Resident Evil 7 and my fps was around 40. Then i enabled stream and fps was around 32 and my screen started blinking sometimes.

I don’t have gameplay with this issue cause it can take ages to catch it on camera, but I found scenario when these blinks happen more often, its in FurMark launched in fullscreen, take a look:

With g-sync enabled i’m getting black flashes:
https://www.youtube.com/watch?v=UmhxbsBjIOc
With g-sync turnd off its clean:
https://www.youtube.com/watch?v=Vh1zPYBuT_0

I found just one mention of such behaviour:

https://devtalk.nvidia.com/default/topic/829054/gsync-black-flickering-on-fps-drops/

Some more info, installed Quake II and binded 2 keys, one will force 5fps lock and another 90fps lock. If i switch slowly between, all is okay, but if i do this fast, screen will blink.

Finally captured some real gameplay. Happens from time to time in Dishonored 2 while game is around 30 FPS:

Okay, finally, after 4 month with this laptop i solved this issue.

Cleaned everything via DDU and installed latest 381.65. No more blinks, even on clock switch.

I’m sorry to revive this thread, but this bug is also reproducible on Linux, and being tracked under internal ticket 200345490

Well, for windows this issue was solved in 381.65 driver and newer.

They broke it again… Facepalm. I’m installing latest driver now, it won’t help I’ll have to downgrade.

Well, okay. No blackouts on 390.77 - WHQL…

@Vorob Thanks for the tip. I had the same issue still and I think I fixed with 390.77 - WHQL as you stated. The latest driver 398.11 - WHQL causes blinking on gsync monitors.