Re-enable UART0 after TX2 boot

Continuing the discussion from Disable serial console of u-boot on TX2:

The accepted solution on the linked discussion (changing the pinmux setting) gives the desired behaviour of disabling UART0 during boot.

After boot, how do I re-enable UART0? The solution suggests:

Then later when/if you need to use UART0/UARTA in say the kernel you can reconfigure it back to HSIO mode for UART support.

… but it is unclear how this would be achieved without re-flashing the board.

@JDSchroeder do you have any suggestions?

You can do it three ways:

  1. Use devmem2 to change the value of the pinmux register
  2. Make a special program that effectively does what devmem2 is doing in a more controlled way (i.e., memory map the address and do the modification within the program). This program could get the setuid permission to allow it to run as root and do the limited secure action of changing the pinmux setting.
  3. Make a simple kernel driver (or modify an existing one) that makes a sysfs property that you can echo to that will cause the pinmux value to be updated correctly to the HSIO mode for UART support. I can’t remember which driver the kernel uses for the Tegra UARTs, but you could even hack in the necessary code in the driver to do the proper pinmux for the UART during the device driver probe operation.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.