Read RTSP give the output when used GPU decoder nvv4l2decoder stuck in loop at certain timestamp forever

Please provide complete information as applicable to your setup.

• Hardware Platform (/ GPU)
• DeepStream Version: 6.0.1
• Issue Type(bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

I run the bellow pipeline: and get output video sink loop in the certain timestamp forver. What is the root cause of this issue?

This pipeline auto choose the decoder is nvv4l2decoder

gst-launch-1.0 rtspsrc location="rtsp://URI" protocols=4 short-header=1 ! decodebin ! queue ! nvvideoconvert ! nvv4l2h264enc ! h264parse ! matroskamux ! filesink  location=nvv4l2dec_gpu_loop.mp4

But I tried the pipeline with CPU decoder without the loop issue:

gst-launch-1.0 rtspsrc location="rtspt://URI" protocols=tcp short-header=1 ! rtph264depay ! h264parse ! avdec_h264 ! nvvideoconvert ! nvv4l2h264enc ! h264parse ! matroskamux ! filesink  location=out_cpu.mp4

This is output have the loop issue. Could you Nvidia developer check the bugs and let me know what is the root cause?

test_cam74.log (49.6 MB)

Video spec:

Video: h264 (High) yuv420p(tv progressive) 1280x960 5 fps 5 tbr 90k tbn 10 tbc

You can try to update the deepstream to 6.1.1. It seems like the topic below:

Thank you could you give me the root cause or release note for this issues? @yuweiw

@yuweiw Incase we could not update the version deepstream. Could we know the root cause and have workaround with it?

Does it necessary need to modified the nvv4l2decoder to get fix?

Yes, it needs to modify the nvv4l2decoder. The root cause related to the compatibility between h264 protocols and nvv4l2decoder lib. So it’s hard to provide the workround.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.