Realsense L515 connected to NX and only USB2.1 is available (it should be usb3.2)

Hi guys,

I have 2 NX development kits and 2 Realsense L515 cameras.
When I connect the L515 to NX sometimes it shows usb2.1.

There are 2 cases:

  1. First time when I plug the L515 to NX, when I run rs-enumerate-devices on Jetson it shows USB2.1 and only low resolution configuration can be used. When I change the Type-C connecting side on L515 it may show USB 3.2 and work normally. (The two sides of type-c connector should have the same result as usb3.2. The cables are from L515 package)

  2. Sometime even I change the connecting sides it both shows USB2.1 and only the low resolution configuration is available.

Who met such cases and give me a hand? Thanks!

The USB recognition is not stable. I don’t know this is the problem of NX or L515.

I don’t know of any 2.1 standard. Are you comparing USB3.1 and USB3.2? Early on USB3 had only the 5Gb/s standard (USB3 gen. 1 just used “3” and did not specify “gen. 1”), and a separate USB2. Later, after a 10Gb/s came along, the 10Gb/s became USB3.2 and the 5Gb/s became known as USB3.1. Basically plain “USB3” was absorbed into “USB3.x” based on being generation 1 for 5Gb/s, and known as generation 2 for 10Gb/s.

A closer description of the issue is probably required, especially the output of “lsusb -t”. Preferably in one working case and in one failing case. I say this because falling back from a higher speed generation to a lower speed generation is not always a bug or failure, but can be. It depends in part on what is inherited going from downstream to upstream (or from upstream to downstream).

Also, if you run “lsusb” when a single camera is connected and showing what you believe to be the correct speed (even if on a Linux host PC and not necessarily from a Jetson, though Jetson output is preferable), you will note that there is an ID for each device. I will pretend that your camera has ID “0955:7e19”, but replace that with whatever the camera ID actually is, and include the fully verbose “lsusb” as well for one of the cameras when working correctly:
sudo lsusb -d 0955:7e19 -vvv | tee log_usb.txt

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.