REB input not being received in Isaac Sim

Hi,

I’m trying to control a robotic arm in Omniverse Isaac Sim through the Robot Engine Bridge using sample Python codelets in a Jupyter Notebook, but the slider doesn’t move the robot. However, I am able to see the robot’s position output change in the Jupyter Notebook when I move the robot manually in Isaac Sim.

This is the USD file: cr3.usd (2.4 MB)

To test the codelets, I used a simple test joint: test_joint (1).usd (24.5 KB)
The test joint works perfectly; communication between Isaac Sim and the Python codelets works as expected in both directions.

I tried setting up the CR3 exactly the same as the test joint, and I even tried deleting all the parts from the CR3 except for two axes to simulate a robot with a single revolute joint. Nothing seems to work, and the issue is the same each time - I can read the positions, but cannot control them with the slider.

Any help would be greatly appreciated!

Hi, and thanks for all of the info, ianqyhong. I’m looking into this and will report back here soon.

Cheers,
Edmar

Omniverse Resources:
Documentation: https://docs.omniverse.nvidia.com/
Tutorial Videos: https://youtube.com/playlist?list=PLZHnYvH1qtObj2Q_QGL3KYsYBOCp2KTZI
Roadmap: Trello
Official Discord Server: coming soon!

@ianqyhong can you match the settings for the physicsScene prim in the cr3 usd file with the same ones in the test_joint usd file?
Specifically set the

  • solvertype to TGS
  • broadphaseType to MBP
  • enableGPUDynamics to False
    Save, reload

Could you try this and let me know if the results are different?

Hi Hammad,

That worked, thank you so much! I cannot believe that I missed those details. Is it explained somewhere in the documentation what those settings do or how they affect the REB communication?

Regards,
Ian

They are not…, but I will make a note to mention that in the docs :)
Some of these restrictions on solver types have been fixed for the upcoming release

1 Like