Record 4kp30 video with Jetson Xavier NX. Filesink: File too large

Hi,

I have a problem when I try to record 4kp30 video.
I am using Gstreamer command:
sudo gst-launch-1.0 nvv4l2camerasrc device=/dev/video0 ! ‘video/x-raw(memory:NVMM),width=3840,height=2160, format=UYVY,framerate=30/1’ ! nvvidconv ! ‘video/x-raw(memory:NVMM),format=NV12’ ! nvv4l2h265enc maxperf-enable=1 bitrate=30000000 ! h265parse ! matroskamux ! filesink location=/media/nx/sd_card/toto.mkv
to record video and save in my sd card.

Everything works well, but after 20 minutes, the pipeline was failed.

Setting pipeline to PAUSED …
Opening in BLOCKING MODE
Pipeline is live and does not need PREROLL …
Setting pipeline to PLAYING …
New clock: GstSystemClock
Redistribute latency…
NvMMLiteOpen : Block : BlockType = 8
===== NVMEDIA: NVENC =====
NvMMLiteBlockCreate : Block : BlockType = 8
NVMEDIA: H265 : Profile : 1
ERROR: from element /GstPipeline:pipeline0/GstFileSink:filesink0: Could not write to resource.
Additional debug info:
gstelements_private.c(346): gst_writev_buffers (): /GstPipeline:pipeline0/GstFileSink:filesink0:
Error while writing to file descriptor 16: File too large
Execution ended after 0:19:11.545523086
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …

Is the problem come from my sd card ? Or from my gstreamer command wrong ?
Please give me some advices.

Thank,
Duong Ng

Hi,
The bitrate is set to 30Mbps and it may eat up the storage size very quickly. Suggest you set bitrate to a smaller value and also set virtual buffer size. May refer to
Random blockiness in the picture RTSP server-client -Jetson TX2 - #5 by DaneLLL

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.