Red screen with "vid_rend: syncpoint wait timeout"


The hardware connection is:


When running a simple capture-display pipeline, the monitor screen turns all red. Terminal printing “vid_rend: syncpoint wait timeout”

ubuntu@tegra-ubuntu:~$ DISPLAY=:0 gst-launch-1.0 v4l2src device=/dev/video1 ! \
video/x-raw,width=1920,height=1080,framerate=30/1,format=UYVY ! nvvidconv ! \
video/x-raw\(memory:NVMM\),width=1920,height=1080,framerate=30/1,format=I420 ! nvoverlaysink
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout

The red screen doesn’t go back normal when I kill the pipeline.

I tried using another 1080P monitor, this issue no longer happen. Can anyone give me some pointers where to start debugging this?



Please run your pipeline with “sudo service lightdm stop” first. Are you on rel-28.2?

hi Wayne,

I’m on 28.1.

I tried several times with lightdm service stopped. This issue never happened. Is this a known bug in pre-28.2 releases? Is it fixed in 28.2?

In my application, I need to detect monitor resolution, so I need the lightdm service on (it loads the necessary X11 libs).


This is a known bug and we have workaround in rel-28.2. (Not applicable to rel-28.1)

Please add below option to xorg.conf

Section "Device"
      Identifier  "Tegra0"
      Driver      "nvidia"
  # Allow X server to be started even if no display devices are connected.
      Option      "AllowEmptyInitialConfiguration" "true"
    <b>  Option      "TegraReserveDisplayBandwidth" "false</b>

Is this issue present on TX1 also?

It should not.