Reference/payload's refinement is ignored

Hello, I’ll try to explain the problem:

  • I have a mesh called SM_ground placed inside SM_ground.usdc.
  • SM_ground has refinement override to look more curvy.
  • I add SM_ground.usdc to LC_107_DIY_payload.usdc as a reference.
  • I add LC_107_DIY_payload.usdc to my scene as a payload.
  • I submit the scene to Queue from Movie Capture.
  • I render the scene with Agent.
  • In the rendered image, SM_ground appears like it has no refinement override applied.

HI @user79641! I tried a similar setup, but I was not able to reproduce this. (Though I didn’t involve Queue/Agent yet.)

A few of a questions for you:

  1. Is the refinement working interactively in the viewport, but not in the rendered images from movie capture?
  2. Can you provide example usd layers in a zip so that we can more accurately debug what you’re seeing?
  3. Is maybe one of these Common geometry render settings conflicting? Particularly, Subdivision Feature-adaptive Refinement.

For the first time, it works in the viewport. It doesn’t work the next time I open it. It should work again if I refresh the refinement setting (untick then tick).

I do not use Movie Capture directly. I only submit it to Queue.

Yes, I have this turned on to fix my other issue: Texture seam - Apps / Blender - NVIDIA Developer Forums

I’m preparing the mesh again, because my current solution is to apply the subdivision in Blender. I will send you via message later.

Try turning that setting OFF and try again. That could be reducing the quality.

Yes that fixes the issue, but I can’t find a way to get rid of the other one, so applying subdivision is solution for now.

Hey. I dug into the normal map texture seams issue a bit and I replied with a potential fix for you: Texture seam - #3 by user79641

If that works out, you can remove the subd refinement workaround you’ve been using and we can resolve this one too.

1 Like