Reflash Jetson TK1 pro


some one of my organization gave me a Jetson TK1 pro that was booting.
I decided to install on my Ubuntu PC the Jetson install to setup environment and reflash the board.
The installation went well but it seems to be impossible to reflash the board. Each time it is stuck in the early phases when nvflash is trying to download the dtb file.

I made all the check and the Board is in recovery mode the “NVidia corp” is present when doing lsusb.
It really seems that the communication is not happening on the USB.

For info i’m NOT using Virtual machine for Ubuntu host machine. I also tried with older version and i have the same result.

Any advises would be very welcomed.


I don’t know if the Pro version uses the same L4T (though probably it does via the ID, but different dtb file). Do you have any logs? Can you verify the dtb file it wants to send exists on the host? Also, was this done as root or sudo?

Thanks for replying .
The dtb the script tries to send is present on the host Nothing is missing and everything was done with sudo rigths.

Regarding the trace there is not so much.

here is the output when board is started in RECOVERY mode
~/NVidia$ lsusb
Bus 001 Device 004: ID 0955:7940 NVidia Corp.

here is the end of traces for flashing after blocks were created

copying flasher(/home/seb/NVidia/TK1/Linux_for_Tegra_tk1/bootloader/ardbeg/fastboot.bin)… done.
Existing flashapp(/home/seb/NVidia/TK1/Linux_for_Tegra_tk1/bootloader/nvflash) reused.
*** Flashing target device started. ***
./nvflash --bct PM375_Hynix_2GB_H5TC4G63AFR_H5TC4G63CFR_RDA_924MHz.cfg --setbct --configfile flash.cfg --create --bl fastboot.bin --odmdata 0x6009C000 --go

i also tried using strace in front of nvflash call to see activity and it seem the script is blocked on ioctl on USB device.

So nothing very help full too debug.


I don’t know about differences with the “pro” version, but if there was USB blocking then I always wonder if the host is a VM or a regular install? The lsusb proves the Jetson is in recovery mode and that the cable is correct.

I had the same interrogation also and it is why i made the try on Native Linux PC and on Virtual Machine and the result is the same on both environment.

But still the same result i’m not able to reflash the board.

I also tried to recompile tegra-uboot-flasher and i have error in that case. It seems to me that communication is happening but finished with errors.

Would it be possible that the fastboot.bin binary is not adapted to my board ?

My understanding is that the Jetson Dev Kit software is not compatible with the TK1 Pro. NVIDIA has advised others in the past to contact the supplier of the TK1 Pro for technical support.

That make sens. Do you know how i can get contact to the “supplier” to get TK1 Pro Installer or equivalent ?

The supplier is the company that originally sold you the board.

Can somebody tell me how I set the TK1 PRO to Recovery Mode ? I can not find the “Force Recovery” button.

Hi Peter_MUC,

Please contact the supplier of the TK1 Pro for technical support.