Registry deepstream6.1-devel


I have tried to pull the image deepstream:6.1-devel from the registry, following the commands from Application Workflow in three different environments Ubuntu 18.04, 20.04, 22.04.

In the extracting phase I get always the same error:
failed to register layer: Error processing tar file(exit status 1): Container ID 71873 cannot be mapped to a host ID

  • Docker version 20.10.17

Could you help me resolve this issue?



This looks like Deepstream related. We are moving this post to the Deepstream forum to get better help.

Thank you.

1 Like

Check if this helps


As far as I know, in a linux env you don’t have to specify the resources that docker is about to use.
However, I’ve tried to pull the image in two different machines which are 16 & 32 GB of RAM, the image size of the 6.1-devel is around 8.8 GB and it fails in both.

Did your docker service running properly?
sudo systemctl status docker.service

Yes, the result is active (running) I can pull other images (e.g. 6.0-devel or 6.1-base) but not the 6.1-devel.
In the attached picture you can find the error when pulling.

I can download the image correctly. it may be related with network.

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.