Regression with vulkan beta driver 415.18 causes shadow rendering issues in GTA V

System Information -
Distro: Arch Linux
Kernel: 4.19.4.arch1-1
Graphics Card: GTX 1080ti

Observed Behavior - When using 396.54.09 vulkan beta I do not experience problems. When using 415.18.02 or 415.18.04, I experience an issue where shadows are not rendered correctly in Grand Theft Auto V via Proton/Steam Play on Linux. More specifically, the shadows seem to move around and take forms that do not match the shapes they are being projecting from.

Expected Behavior - The appearance of shadows in GTA V when using the 415.18 driver should match what is seen when using the 396.54 driver.

Steps to reproduce:

  1. Install the latest vulkan beta drivers for Linux (415.18.04 as of right now)
  2. Install Grand Theft Auto V via Steam.
  3. Install mscorefonts (this is needed for the game to work correctly)
  4. Right click on Grand Theft Auto V in Steam client -> Set launch options -> PROTON_NO_ESYNC=1 %command%
  5. Launch Grand Theft Auto V
  6. Enter the settings menu, enable dx11, and make sure “soft shadows” setting is set to “sharp”, “soft”, “softer”, or “softest” (the problem is not reproducible when you select “Nvidia PCSS”. However, that produces noticeably less detailed shadows compared to the “softest” setting which works for me in 396).
  7. Move around in an area with a lot of visible shadows (this is best observed outdoors when the sun is low, but not fully set)

nvidia-bug-report.log.gz (104 KB)


Bug has been filed with reference ID - 2456727.

Setup is completed and I am able to launch game now. Can you please share small video or screenshot where shadows are not rendered correctly so that I will be able to verify the same.

I just attached 2 screenshots to the initial post. One of them using the “softest” setting, which displays the issue. The other using the “nvidia pcss” setting, which does not demonstrate the issue. I am having a hard time capturing a screenshot with the 396 driver, as it appears as a black window to my screenshot tool. However, I can confirm that the “softest” setting under the 396 driver looks more like the “nvidia pcss” screenshot I provided you in the sense that it does not have the horizontal shadow lines that can be seen in the background of the “softest” screenshot. To produce this, I simply rested at home in bed (this fast-forwards time to morning), went outside, and waited about 30-60 seconds for the sun to come up enough to cast shadows on the fence.

Hi Lyle,

With the information provided by you in above comment, I installed driver 415.18.04 and lunched game.
I took screenshot almost at same location with both settings “nvidia pcss” and “softest”.
Attaching the same for your reference. Although it looks similar to me but I defer to you for observation to see if its relevant to your original issue.

I would really appreciate if you can post a small video clip with both settings “nvidia pcss” and “softest” and highlighting the difference on the same so that we can try for repro in house.

That doesn’t look like you have successfully reproduced the issue to me. I’ll upload a video and include my full in-game settings in the video as well. Please forgive the low quality encode. I was trying to keep file size low. The issue should still be clearly visible. I would also like to point out that the nvidia pcss clip begins just after the softest clip ends.

I’ve also uploaded another nvidia bug report because I think I might have uploaded a bug report from the 396 drivers in the initial post.
GTAV-Softest-Proton.ico
GTAV-NVIDIA-PCSS-Proton.ico
nvidia-bug-report.log.gz (632 KB)

I recorded it again with the 396 drivers using the Softest setting. I hope being able to compare the videos is more useful. I don’t think screenshot comparisons really do the issue justice.
GTAV-Softest-Proton-396.ico

Repro attempted on Ubuntu 18.04 along with game settings provided by you but no luck. Will try to reproduce issue on Arch Linux today and update the same accordingly.

@lyle.tafoya the 2 clips looks very similar to a shadow rendering issue I noticed in another game with DXVK https://devtalk.nvidia.com/default/topic/1044007/415-13-regression-shadows-stretched-flickering-in-sword-art-online-hollow-realization/#5298546

@amrits your GTA V key is visible in your screenshots…

Hi Lyle,

I Installed GTA V on Arch linux but while launching a game, I am facing problem wtth social club rockstar client. Attaching the error screenshot for your reference. Please let me know if you have been through the same error.
Moreover, if you have any other game listed from steam where you have been facing shadow rendering issue, please let me know.

Hi Lyle,

Since I was facing issue while launching game on arch linux as explained in comment #8, I again installed GTA V on Ubuntu and applied settings as per comment #1 but unable to repro issue.

Please review my comment #9 and provide information as per your convenience.

@amrits Also experiencing the same issue as @lyle.tafoya using Proton 3.16-6 Beta, there appears to be a regression within the latest NVIDIA drivers (tested on Ubuntu 16.04 LTS):

NVIDIA 396.54 works as expected

NVIDIA 415.25 displays incorrect shadows

Hopefully this can be resolved in a future point release.

Hi,

I am facing hard time to launch GTA V on Arch Linux due to social club account error as explained in comment#9.
Although I was able to launch it on Ubuntu 18.04 successfully but didn’t get any repro.

@mimattr,
Can you please share nvidia bug report and confirm desktop environment you are using to play GTA V.

Also please confirm if you are experiencing shadow rendering issue at particular map location or everywhere in game.

Did anyone ever try removing/moving the shader cache ~/.nv ?

The default/standard GNOME desktop environment was used on Ubuntu 16.04.5 LTS (Xenial)

The issue can be found at any location within the game though most visible when driving through open busy city areas or along valley tracks, day or night (see previous GIF examples)

Unfortunately removing the ~/.nv cache directory does not resolve the issue.
nvidia-bug-report.log.gz (626 KB)

Nvidia bug report:
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Thanks for the information, the previous post has now been updated.

I used the same system Dell XPS 8700 & installed OS Ubuntu 16.04.5; used GPU GeForce GTX 970 and driver 415.25 but still not able to repro issue.
Please confirm if you have made any specific settings in game or anywhere else which I should take care to repro issue internally.

Interesting, the only difference now is we’re using the NVIDIA 415.27 driver:

https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

For consistency please test using the following commandline.txt configuration:

-ignoreDifferentVideoCard
-UseAutoSettings
-DX11
-cityDensity 0.8
-fullscreen
-width 1920
-height 1080
-anisotropicQualityLevel 8
-frameLimit 0
-grassQuality 2
-multiSample 2
-SSAO 1
-shaderQuality 2
-tessellation 1
-textureQuality 2
-waterQuality 1

Your continued effort and time on this issue is greatly appreciated!

We just released a new Vulkan Beta Driver 418.31.03 that contains a fix for a bug that would occasionally cause visual corruption on some Vulkan titles. This bug was particularly prevalent on DXVK titles. Please check if this new driver resolves the issues that you’re encountering.