Reinstalling cuda toolkit due to installing a new card

I have a working cuda 9.1 with a M2000 (sm_50). I have installed the toolkit via the runfile. Now, while M2000 is present, I have installed a Tesla C2075 for some testing purposes.

I want to know if I must install the toolkit again. Any idea?

I ask that because, I have build a new lammps with sm_20. Now, when I force the application to use gpu 2 (tesla), I get an error which says

GPU library not compiled for this accelerator.

CUDA 9.1 does not support Tesla C2075

The last CUDA toolkit that supported that GPU was CUDA 8