Rel-32.7.2 patching /boot/Image won't take effect


I am working on an NVIDIA AGX 32GB (Jetpack 4.6.1) for a project at the moment. We are connecting a switch with 2 cameras to the ethernet interface of the Jetson and while setting the MTU to 9000 it reboots. I saw that you were active in some discussions about this problem, such as in ‘High MTU causes Kernel Panic - #23 by k-hamada’. The Jetson supplier prepared the patch of the /boot/Image for us. After applying this patch on one Jetson, it kept on restarting with higher MTU. However after a week of developing other stuff (with MTU 1500), suddenly the MTU 9000 worked. On the second Jetson we again see that it restarts after applying the patch+MTU 9000 and we don’t have the time to wait multiple days, due to being in another country for the project.

We replaced both the /boot/Image and the /boot/Image.t19x files with a patched version which should allow this higher MTU.

This resembles a comment posted on

1. If you only replace /boot/Image in rel-32.7.2, **it won’t take effect due to a known bug.**
2. Those instructions in the document has nothing wrong. Please do not mislead other users.

Is there a solution for this rel-32.7.2 bug (without reflashing)?


Please apply this patch to cboot. And this requires flash.

Thank you for the fast reply. Does this reflashing cboot really require connecting an external (Ubuntu 18.0.4) device and running a flashing script? Our Jetson is integrated in a production closet, so I would want to avoid unmounting and opening it up. Is there a way to manually update this /boot/Image patch from CLI, without fixing the kernel in the long run?

You can also try to use bootloader updater to do that. But I personally don’t think this is easier than directly running\

Basically, this tool is

→ generate a binary on your host, which includes every bootloader → send this binary to device
→ run update tool on device and it will update the binary to your device.

I haven’t tried it, but I assume you can upload the recompiled cboot.bin file to the device, and then run “dd” to write it to the partition that holds it.

Looks like someone else tried it: Unable to use dd to flash updated cboot

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.