Remote Desktop Session Host

Hi all,

I’m having an issue that is preventing me from creating an Automated Farm in VMWare.
I have installed RDS on a windows 2016 server as stated in documentation from VMWare.
I have installed the GRID card as stated and get a response from it as expected.
I have added the card to the RDS server and installed the drivers.
I have installed the view agent and enabled the 3d RDSH option and pointed it at the connection server.

Everything shows up in view manager as you would expect it to, but when i come to select the default image snapshot, there are none to choose. I click the show all images option, and select my RDS server, and i get teh following message:

"Snapshot NVIDIA GRID VGPU support does not match desktop setting"

I’ve searched google and not really had much success in finding a solution. Has anyone come across this before?