Remote visualization error (GPU cluster)

We are having a GPU cluster installed in our lab. It has one master node and three compute nodes. Each compute node is equipped with two tesla K40 GPU cards. The installation of the cuda toolkit, nvidia drivers are completed.

Our task is to do remote visualization and we have found the following white paper by NVIDIA,
www.nvidia.com/content/PDF/remote-viz-tesla-gpus.pdf

So, we have connected one of the compute node remotely from a machine (having GeForce card) and tried to run the simulations examples (such as, smoke particles, oceanFFT etc.), those came with cuda toolkit. But it is showing following error,

[root@compute-0-3 release]# ./smokeParticles
CUDA Smoke Particles Starting…

NOTE: The CUDA Samples are not meant for performance measurements. Results may vary when GPU Boost is enabled.

Loaded ‘…/…/…/…/5_Simulations/smokeParticles/data/floortile.ppm’, 256 x 256 pixels
CUDA error at ParticleSystem_cuda.cu:91 code=10(cudaErrorInvalidDevice) “cudaMalloc3DArray(&noiseArray, &channelDesc, size)”

Please help
thanks

https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

hi,
could you help me to install the nvidia drivers on my cluster? I have scyld clustware installed on centos 6.6. I have 15 nodes and just the nodes 12, 13, 14 and 15 have GPU. So, I installed the cuda toolkit on master node, and it is ok, now I am trying to instal the nvidia driver from master node and it says that it does not have gpu card on there, that is correct (there is no gpu on master node). I tryed to install the drivers on the other nodes but it did not work.
It is my first time doing that. I need some help.
Thank you.