RemoteFX Display Problems with Windows 8.1 VM but not Windows 7 VM running on Windows Server 2012 R2

Please Help, Nvidia.

Has anyone seen this?

The display shows many random fuzzy polygons, random color blocks, snowlike artifact etc. It happens randomly, including home and start screens. It is not constrained to a specific running program or application. It is not specific to a screen area.

This problem is identical using multiple versions of NVIDIA Quadro/GRID drivers including latest (347.25). It is identical using NVIDIA Quadro K2200 and NVIDIA GRID K2.

The VDI/Hypervisor is Windows 2012 R2 Hyper-V with vGPU RemoteFX properly setup. The client VM with a problem is Windows 8.1 Enterprise.


  1. RemoteFX adapter is added and enabled in Hyper-V and added to Windows 8.1 VM the problem is present.

  2. RemoteFX adapter is added and enabled in Hyper-V and added to Windows 7 VM the problem is not present.

  3. RemoteFX adapter is removed from Windows 8.1 VM the problem is not present.

  4. RemoteFX adapter is removed from Window 7 VM the problem is not present.

This is being tested with 1 VM at a time in order to eliminate variables, It is not Load related, and is present on multiple RDP clients. I know the vGPU is working when passed through as both VM’s are able to use Direct3D etc. The acceleration is working but it is like a buggy video driver when the client VM is Windows 8.1

As the RemoteFX driver that you have in the VM is provided by Microsoft, I would recommend raising this through the MS support channels.

The Microsoft driver communicates with the Nvidia driver in the host and in doing so is translating the API calls from the application, and those that are returned by the Nvidia driver.

It is effectively abstracting and translating calls from the application and OS before passing them to the Nvidia driver, and so Microsoft should be the first port of call for troubleshooting I’m afraid.

Yes, I have been in process of working through it with Microsoft. As I mentioned, it works perfectly with a Windows 7 VM not Windows 8.1. I would however like to see NVidia more interested in testing and providing a solution. It certainly would make me consider not getting a comparable AMD/ATI GPU. As it stands now the path of least resistence for me would be to get an AMD/ATI FirePro W5100 or higher and test that.

The FirePro W5100 is PCIE 3.0 and comparable to the Quadro K2200. The FirePro S10000 is somewhat analogous to the Grid K2…

Please help by testing in a lab with the above mentioned NVidia GPU’s…

I’ve been unable to replicate this, but it doesn’t mean it doesn’t exist.

I think you’ve identified that the cause is the Microsoft driver in the Windows 8.1 VM already.

Since this driver is Microsoft’s it’s not something we can resolve for you. The Nvidia driver in the hypervisor is the same regardless of the guest OS, it’s the Microsoft driver and how it manages translation between itself and the driver in the Host that is the source of your issue.

Has Microsoft responded with any resolution yet?


Thank you for keeping an interest here. No, Microsoft has not resolved the issue. I do understand the complexities related to this.

The frustrating part of the issue is that it is much, much, much easier for me to just get another vendors GPU and test it than try and wade through finger pointing sessions. I am slso sure that your relationship with Microsoft much closer than mine. NVidia makes millions if not billions of products used with Microsoft Operating Systems…

Microsoft helps you sell GPU’s and you help Microsoft sell OS’s.

I’m sure someone there at Nvidia tests GPU’s with RemoteFX and could reliably reproduce the issue.

As mentioned the problem is on Windows Server 2012R2 and is present in the guest OS on Windows 8.1 but not on Windows 7 SP1. It is present on all RDP client software that was tested. Multiple PC versions, Thin Client, Zero Client, etc.

Had exactly the same problem. That’s how I fixed it:

Open up device manager, bring up the RemoteFX vGPU and click on "update driver software". Then, click on the "Let me pick from a list of device drivers on my computer"-option.

You will see two RemoteFX vGPU devices on that list. Chose the first one, let it install, and those artefacts are gone!

This fix has some interesting side-effects though: The metro interface gets bugged! If you search for something from the home screen, it will just flicker but nothing will happen. Metro apps will start and then minimize within seconds. Also, Internet Explorer (desktop version) will crash.

We use Classic Shell and Firefox, so nothing of that is important for us though. Everything else works without any problems and the artefacts are gone.

It’s pretty interesting, that apparently Microsoft’s “metro”-gifts were the main reason the RemoteFX driver had to be modified, and they bugged out on it.