Render increase clock ros/wall time (sim time)?

Self explanatory…
When I call simulation_context.render() clock is advanced :( I do not expect that though, clock should increase at complete step/phyisics step.

NOTE: it is published correctly only when ticked.

Seemingly, this is also explained in the clock.py example. However, it would be nice to have the option to tick it manullay.

Found the solution.

However, I might suggest to add this in the clock/rosbridge init command as ppl might want to step clock with the physics (as sensors like imu should publish with the physics step not the render).

omni.kit.commands.execute("RosBridgeUseSimTime", use_sim_time=True)
omni.kit.commands.execute("RosBridgeUsePhysicsStepSimTime", use_physics_step_sim_time=True)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.