Replace Unity with lubuntu

I was wondering if anyone knows how to remove unity and replace with lubuntu? I have tried to use apt-get install lubuntu-desktop but i cannot be found. I upgraded the repos (apt-get upgrade and also updated). I also found a ppa for lubuntu and added that but no luck (when i go to update its a 404 error when it tries to access the site).

Also I was wondering if this is even worth it in the first place. Unity seems to run somewhat slowly, so I was thinking that since lubuntu was more light weight it might be faster (but I don’t know if there will be issues with some CUDA or openGL stuff down the road).

Any help would be appreciated. Thanks.

Lubuntu is Ubuntu with LXDE as the default desktop. I use XFCE, another light weight desktop.

I think you can install LXDE with simply:

sudo apt-get install lxde

This is what I’ve used to install XFCE:

sudo apt-get install xfce4 xfce4-goodies

You can install as many different desktops you want. Having them installed takes some disk space but nothing more. When logging in using the lightdm login manager, you need to select which desktop you want to use.

Some desktop environments (like Unity) use “composition”, i.e. they render all the windows with OpenGL to a single full screen buffer and then ask X.Org to show it on a screen. That allows all kinds of cool 3D accelerated effects, like having different virtual desktops in the sides of a cube but that of course adds some overhead. XFCE can also do composition but that’s off by default.

Unity lags because CPU when on ondemand governor, doesnt scale properly. It stays on low frequencies even when doing more intensive stuff. You can force cpu on performance governor. I use indicator-cpufreq for that. Useful app.

@kulve does Unity or stock lockscreen get affected in any way if you install xfce? I ask because when I installed KDE, Unity didnt work anymore and I ended up in reflashing system

Thanks for the replies.

@kulve is it possible to uninstall unity while just keeping xfce? If so, how would I remove unity? Also for some reason when I try the “sudo apt-get install lxde” it says package not found (just like with sudo apt-get install lubuntu-desktop (or sudo apt-get install lubuntu-core or sudo apt-get install lubuntu-meta))

@MiFx so the indicator-cpu is an app that you run in Unity? Also do you know of a way to permanently fix this? Like is there a library or change in the kernel configuration that would fix this?


You need to edit some file but I dont know which. indicatot-cpufreq runs in any desktop environment. Its just a drop-menu from the top bar in Unity

For some reason it looks like the LXDE is part of the Universe and not the main set. Try enabling the universe and then try installing it again:

sudo add-apt-repository universe
sudo apt-get update
sudo apt-get install lxde

And yes, you should be able to uninstall Unity but I don’t know what all packages comes with it, i.e. what all to uninstall. I think it’s easier to leave them unless you have a reason to remove something specific.

An even better way, IMO:

sudo apt-get install tasksel
sudo tasksel

(One also can select other Ubuntu flavors, Kubuntu, Xubuntu, etc.)

MiFx, thanks so much about the tip about the ondemand govenor not scaling correctly. I am not using indicator-cpufreq and performance drastically improved. Many people have complained about Chromium being sluggish on the Jetson but this definitely solves that problem. Does Nvidia know about the CPU scaling issue?

@derrick313 ondemand scaling is problem even on my Asus Tegra 3 tablet. When I switch from interactive to ondemand, tablet feels very sluggish which is complete opossite from interactive

Checking in with one of our engineers, switching the performance governor from “ondemand” to “performance” may not be the best way to reduce the sluggishness. While it does improve performance, it does so by setting the CPU frequency to the highest available, leading to high power consumption and CPU temperatures.

An alternative way to increase performance is to reduce the ondemand governor sampling rate from 300ms to 30ms. Here’s the commands to do so:

$ sudo chmod 666 /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate
$ sudo echo -n 30000 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate

You can also modify /etc/init.d/ondemand to change the sampling_rate file when system boots up:

    start-stop-daemon --start --background --exec /etc/init.d/ondemand -- background
    sleep 60 # probably enough time for desktop login

    [ -f $AVAILABLE ] || exit 0
    read governors < $AVAILABLE
    case $governors in
            exit 0

    for CPUFREQ in /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
        [ -f $CPUFREQ ] || continue
        echo -n $GOVERNOR > $CPUFREQ
    if [ -e /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate ]; then
echo -n 30000 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate

We are planning to fix this ondemand governor performance issue in a future L4T release.

@ctichenor Thanks for that :) (about high temperatures when using performance, I can say that they are well below 40C with stock cooling and room temp of 22)