Replacing the Power Supply of the Original Carrier Board

Hi,

I’m trying to use my own power supply with the official TX1 carrier board. I was able to acquire the correct connector (the connection and polarity was verified with a multimeter), and I connected a lab power supply with the capability to supply up to 10A to it.

However, the board doesn’t start up with this power supply, the two green LEDs don’t light up when I press the power button. I tried an input range of 12-19V to no avail. I also tried another power supply that delivers 13.8V at 5A max.

The current limiting LED of the lab supply does flash up briefly, though. When I attach an oscilloscope to the 5V IO rail, I saw that it rises briefly and then bounces back to 0V.

Does anybody have any idea what’s going on? It looks like the inrush current is too high for the my power supplies, but the TX1 shouldn’t have that high of an inrush current I believe.

The board itself still works, I reconnected it to the power supply that came with it and it booted up fine.

A 10A lab supply should be fine. Anything from 12-19V should also be fine. Beware that the connector has nearly-duplicate variants out there which only “appear” to be the same thing…you might have one of the connector versions that looks like a match but is off by a fraction of a millimeter.

I verified the contact using the continuity testing feature of the multimeter. I got a 5.5mm outside/2.5mm inside barrel jack plug. The 5.5mm outside/2.1mm inside (which is the most common one) doesn’t fit at all.

The specs of the plug also say that the inner diameter is 2.5mm, so that should be ok, even when I’m not using the official plug (I can’t find that exact one on Octopart, Mouser or DigiKey).

I think I’ll try using a regular 12V power supply next. Maybe the current limiting behavior of the lab supply is the problem…?

Foldback current limiting should bring voltage and current back up as the load decreases, e.g., as onboard capacitors become charged. I just doubt that any capacitor or component would cause an initial surge that would get in the way of a 10A rating.

As an experiment, what I’d suggest is to create a short extension cable to the provided adapter. Basically something like a six inch extension cable with compatible connectors going straight to the JTX1 and straight to the provided power supply. If desired you could perhaps put in something like a 0.1 ohm resistor and watch the current spike on an oscilloscope as the unit powers up to see if this is really an issue. The same cable might provide additional testing to whatever bench lab cable connector you use as well.

I obtained the parts as needed and tested it. When I connect the original power supply through my adapter, it also doesn’t start up. This leads me to conclude that the plug I’m using isn’t suited, even though I can measure the 19V on the solder joints on the carrier board. I suspect that the contact is there but has a high enough resistance to let it break down once current is drawn.

The difference I can see is that the original plug has a spring system for the center pin, while the ones I was able to find do not.

In any case, here’s the oscilloscope measurement of a 0.1Ω resistor in series with the original power supply while pushing the power button:

That shows a maximum surge of just under 1A, so definitely a 10A supply would never hit any current limiting feature. If you find a correct/known-working connector part number, I’m sure many people would be interested.

The strange thing is, when I connect the oscilloscope probe to the solder joint of the connector on the carrier board, there is no voltage drop at all when trying to turn it on. I’m unable to measure any difference between my plug and the one of the official power supply.

I found a different 12V power supply with the same spring system plug, and the board starts up fine from this one as well.

Unfortunately, there’s no VIN exposed on the pin headers, otherwise I could supply the power via that avenue. I guess it’s not a good idea to supply the board via the 5V rail, bypassing the first stepdown converter?

This one might fit: http://www.cui.com/product/components/connectors/dc-power/plugs/modular/pp3-002bh

Note that it’s rated only up to 16V@8A, so it’s no good for the official power supply, but should work fine for 12V.