Req.Support for NVIDIA JETSON TX2 reh

We are working on NVIDIA JETSON TX2 from our vendor in the past for a project.Currently would like to use the same board to deploy our application related to Image Segmentation.
We could run the file.
However, couldn’t load the .h5/.h5py model files.
It is raising
Import error:asking for .h5py file,even though it is available.

Packages installed in board are python3.5,tensorflow 1.8


Import error:asking for .h5py file,even though it is available.

Based on this error, it seems a missing library issue.
Have you installed the h5py library first?


Hi AastaLLL,

I have tried to install h5py library.It is giving dependency errors.

Could install python-h5py library

Upgrade to python 3.6, and on trying to install h5py ,the following error is coming


May I know which JetPack do you use?
It’s recommended to use our latest software which should come with python3.6.


I couldn’t install jetpack,unable to select target is from nvidia SDK.,though I am not using vm

Could you please look into this issue soon?


Which JetPack do you use currently?

$ cat /etc/nv_tegra_release

If SDK manager doesn’t work, have you tried our OTA feature as below?


Yes…tried this option…but landing in errors

Hello @user121440 ,

Based on the latest ss that you have shared:

  1. Sub-process /usr/bin/dpkg return an error code(1)
    This error arises when your installed packages are either corrupted mainly when they are interrupted while installation.
    If apt- get clean is not working please try the following command:
    sudo apt-get remove --purge eog

if possible try to reflash the OS and start package installation again.

Highly advise you to not interrupt any package installation process.

  1. h5py Installation
    Do not install the latest version of h5py, try the following version:
    h5py==2.10.0 (try any version less than 3.0)

Let me know if this works.


My host system has O’s version Ubuntu 20.04.3 lts .so could you please suggest the ota packages suitable for the same

The issue is with the previous packages and their repository that you might have tried to install.
Since it is not able to locate the packages, can you send ss of software & updates → Ubuntu Software?

Hi hitesh…
My main idea is to run a trained model(.h5py/.pth.tar) on jetson tx2 board.

Is there any method without installing jetpack?

Tried using Ubuntu 16 as host…still not working