Request: GPU Memory Junction Temperature via nvidia-smi or NVML API

I’m running that tool but no Memory Temp, just GPU Temp, any additional conf?

I didn’t do any additional configuration, does your GPU have a memory temperature sensor?

it’s working! I had to run the clitool with sudo (risky, I know) and started to show detailed data including Junc and Mem Temp + Volt and Temp for CPU.


1 Like

thanks, since nvidia doesnt care this is the only option.

This worked yesterday, but not anymore today. Anyone else having problems? Didn’t make any changes to the system and tried a reinstall.

Same issue here, worked fine yesterday morning but when I tried to run it in the evening and program died before the “Detecting GPUs” prompt. Same this morning as well, made no changes prior to this, have since tried downloading a new copy, creating a new .json file, rebooting, still nothing.

sorry, but, XDDDDDD

So this tool requires internet connection to activate this functionality? That is sketchy. I hope someone can reverse engineer this to produce a simple offline open source utility…

Hello, I made this video. I just stumbled upon this thread while looking for information on clitool. Here’s what I can tell you all:

  1. The clitool binary is straight from mmpOS. You can verify this by checking the MD5 checksum of clitool within mmpOS 3.0.3 and the clitool I link to in Google Drive. They will be the same.
  2. An internet connection is required for the moment. This is because the tool itself connects to mmpOS servers.
  3. You have to make your own mmpOS rig for it to work now (Take your rig_code and id and replace it in the commands). Mine (Which people were using) kept getting deleted for some reason.
  4. No, it’s not open source. In fact, I am unsure where/how mmpOS devs managed to implement GDDR6X memory temps in their OS, and that is currently what I am trying to figure out. I am not a software engineer by trade, but I am a tinkerer at heart.
  5. As far as I can tell, the temps are real. I cross tested w/ mmpOS windows agent and within mmpOS itself, and saw the exact same values for the same 3070Ti under the same load. Again, not sure how, but I am doing my best to figure it out.

Hi all! Trying to get mmpOS clitool working under bare Linux…

I did create a new rig under mmpOS, configured and let it work for some minutes. Internal clitool showed proper mem temps, so everything great there. Back to my Linux box, created config.json file with the help of rig_code from web/add rig + ID from mmpOS command “debugme”, and finally was able to launch clitool without problems.

The only drawback is that there’s no MEM temp now :) Only GPU temp. clitool detects GPUs, CPUs, whatever, but doesn’t show MEM temp, even when mmpOS and my Linux Nvidia driver is the same (470.103.1)

Any ideas?

use sudo to run clitool, I had the same issue

Yeah, I read about it and tried with root also, but same results except for the Ryzen CPU (which doesn’t show as a normal user)

still nothing after 9 months…

so… @wpierce any updates ?

How many years we need to wait to get a solution?

We need to use a famous “clitool” from MMPos ?

NVIDIA is a fucking joke. I can’t believe we need a major data hack and third-party developer action just to see memory temperatures on Linux.


we are still waiting…
Please do it before the end of our world! After that moment this tool will no longer be needed :D

gminer v2.88 just started supporting gddr6x memory temperatures under linux. tested it out - works. That means it’s possible to get mem temps under linux :)


Is there any news on some open source tool that exploits whatever data was leaked from nvidia to read memory temps?

GMiner got this on board already!