[RESOLVED] DriveInstall 5.0.5.0b prerequisites for host PC

Hello,

I have a host PC with Quadro M2000M GPU running Ubuntu 16.04 LTS. I have some queries regarding installation of the DRIVE SDK.

  1. My GPU is currently set to use the Nouveau driver. Do I need to change this behavior so that the GPU uses the NVIDIA driver before running DriveInstall? If I continue to use the Nouveau driver and run DriveInstall, does that change the way the DRIVE SDK is installed?

  2. By default, Ubuntu 16.04 LTS has GCC version 5.3.1. But the DRIVE Linux, DriveWorks, and TensorRT release notes seem to recommend using a lower version of GCC. What is the most appropriate version to use?

  3. By default, Ubuntu 16.04 LTS has CMAKE version 3.5.1. But again, DriveWorks release notes seem to recommend using a lower version of CMAKE. What is the most most appropriate version to use?

Thank you.

Dear sagar,
The system should have minimum Maxwell based GPU. The Drive installation requirements are at Autonomous Vehicle Development Platforms | NVIDIA Docs
Driveworks requirements are at file:///usr/local/driveworks-0.6/doc/nvdwx_html/dwx_samples_building.html

Do you see any problem while installing Drive Install?

Dear Siva,

As I said, I have a Quadro M2000M GPU.

I feel that these requirements are a bit unclear.

Two conclusions from this:
(1) Ubuntu default GCC version 5.3.1 should work for successful DriveInstall. But section 2.9.3.1 of https://developer.download.nvidia.com/driveworks/installers/driveinstall/secure/5.0.5.0bL/NVIDIA_DRIVE_Linux_5.0_DPX_Release_Notes_5.0.5.0b.pdf states that DRIVE Linux requires GCC version 4.9.2. So which version should I use?
(2) Ubuntu default CMAKE version 3.5.1 should work fine for DriveInstall.

I haven’t…yet.

And what about the GPU driver?

Thank you.

Dear sagar,
GPU driver should not be a problem. We will update the documents to avoid confusion. Thanks you.

Dear Siva,

Thank you for your reply. If you could resolve the outstanding question from my earlier post, we can close this thread.

Hello,

Any update on this?

Thank you.

Dear sagar,

As stated in the document, this is for cross-compilation.
GCC Cross-compiler Toolchain for user applications and libraries : 4.9.2
After installing gcc-4.9.2 you should be able to call cmake with:
CXX=g+±4.9.2 CC=gcc-4.9.2 cmake {cmake options here}

Understood. Thank you very much. Appreciate your help.

Hi
Nvidia Geforce GT 740 give me a problem when i update the latest driver it give me aan Error Code 43 when i update the latest drivers 398.82 but when i install the cd that came with it works fine but the game is asking me for the latest driver. Please assist
Windows 10 pro
I7
4G Ram
Nvidia Geforce GT 740 4G

Dear Wgiliams99,
This forum is intended for Drive platform related queries. Can you please create a separate topic on your issue in GPU forum to get it answered by our team.