RESOLVED - New user - Cannot get V.7 samples to compile in VS 2013

I installed CUDA V.7 and everything appeared to install correctly.
I tried to compile with my VS 2010. many errors related to not finding .h files. Research indicates they needed to be downloaded from MS and installed.

VS 2013 according to other research supposedly includes the whole windows SDK (which now apparently includes the D3D___ files) supposedly.

I just purchased my MSDN subscription and VS 2013 Pro (patch 4), installed it and all appears to work fine. Except!

I tried to compile the CUDA v.7 samples solution and first time through 155 errors. Did a full rebuild (2x) and now stuck with 26 errors, all are related to d3d… 9, 10 and 11 .h files.

what am I missing here, I thought VS 2013 was supposed to be all I needed with V.7

help, please.

P.

You should reinstall CUDA 7 after installing VS 2013.

Why not just download and install the windows SDK ?

I could not find the SDK one the windows web site. after 30 minutes of looking, almost everything I found was MS pushing VS 2015 Beta. I finally went the subscription route and went with 2013.

I will try re-installing Cuda v.7

(I am on a win 8.1 machine with a GTX 980 so I figured I might as well upgrade to VS 2013 also. )

I should also note that I already did have VS 2013 "Community’ on the machine earlier when I first installed the CUDA 7.

Thanks

??

google search “windows SDK”

Immediately returns a number of promising links including:

https://msdn.microsoft.com/en-us/windows/desktop/bg162891.aspx

You may also want the directX SDK (again, via google):

https://www.microsoft.com/en-us/download/details.aspx?id=6812

Thanks.

I tried a google search and that’s when I started seeing all comments that the Windows (and directX) SDK is no longer standalone and is now in the VS.

I will try the link after the finish re-installing 7

thanks.

Reinstalled Cuda 7, had to do it 3 times before everything went in.

used the links you provided and installed them (had a problem though with 'redistributable runtimes not installing but don’t know yet is that will cause problems.)

And, it looks like all the sample apps run fine

P.

A.I. Rules!