Restoring DRIVE PX 2 to its factory settings

Dear respectful experts,

I have made a lot of changes to my DRIVE PX 2 system which are beyond tracking. As a result of the said changes, I am lately getting problems when I start up the system and get the login screen. Whether I login as nvidia or ubuntu or even as Guest, after inserting the credentials in the password field, the screen goes blank for a while and gets back to the login window over and over. I do need to restore my system to its factory settings. Is there a way to do that?

Sincerely,

Riyadh Kenaya

We ran into a similar issue. Our TegraB was not working but TegraA was working.

You need to link a missing library. I will get that for you tomorrow.

Hello Sumit,

Thank you for yuor prompt response. I will be waiting for the said link patiently.

Riyadh

Hello Sumit,

I am still waiting for your solution. It has been more that 24 hours now.

Riyadh

Hello RiyadhKenaya,
Could you please check your using PDK version?
AFAIK, Alpha version has similar issue.
If you has still same issue with Beta 1.0 PDK, could you please file a bug on partners.nvidia.com? Thanks.

https://developer.nvidia.com/driveworks-sdk-downloads
Reporting Bugs: If you have not found what you were looking for in documents included with SW package, Release Notes or Tips/tricks and would like to request for a new feature or report an issue please use “Report a Bug” link in your NVONLINE account (partners.nvidia.com)

Sorry about the delay. I cannot find the exact file but the issue was my TegraB was not finding libEGL (You need to create a sym link from some nvidia folder in /usr)

Sorry I don’t remember the exact details.

Dear Nvidia,
I have hit the similar problem with my Drive PX 2 which is connected via Tegra A. However, my problem is slightly different. Let me explain my problem step-by-step.

  1. Login to drive px 2 with uname/password
  2. After successful login, i see a black screen. Previously I used to see a logo (Drive PX 2) which is missing now.
  3. I open a terminal by pressing CTL+ALT+T
  4. It opens up a terminal
  5. When a drag the terminal from one location to another location within the same screen, it shows me multiple terminals (I guess, it is not cleaning up the previous trailer). And all those terminals started blinking.
  6. At this moment, I cannot do not anything except rebooting the Drive PX 2

There is something messed up. Please help me, How can i revert back to original factory settings?

Appreciate your help.

Thanks
Sam

I tried running the below command to re-install the desktop, but I got the error (gstreamer1.0-alsa but it is not going to be installed. You can see the detailed error below).

nvidia@tegra-ubuntu:~$ sudo apt-get install --reinstall ubuntu-desktop
[sudo] password for nvidia:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ubuntu-desktop : Depends: gstreamer1.0-alsa but it is not going to be installed
Depends: gstreamer1.0-plugins-base-apps but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
nvidia@tegra-ubuntu:~$

Dear SamJey,

Sorry for the inconvenience.

May I know your DPX2 SDK version?
If DPX2 SDK version old(Beta 2.0, Alpha 2.0,…), could you please update DPX2 SDK to Beta 3.0(NVIDIA DRIVE 4.1.8.0)?
We had released DPX2 SDK to Beta 3.0(NVIDIA DRIVE 4.1.8.0) on https://developer.nvidia.com/nvidia-drive-downloads. Thanks.

Dear Steve,
Thanks for your reply.

  1. I have downloaded DriveInstall_4.1.8.0L_SDK_b43.run

  2. chmod +x DriveInstall_4.1.8.0L_SDK_b43.run

  3. I started installation
    nvidia@tegra-ubuntu:~/Samuel$ ./DriveInstall_4.1.8.0L_SDK_b43.run
    Creating directory _installer
    Verifying archive integrity… All good.
    Uncompressing DriveInstall 100%

  4. A xmessage window popped up showing the below error
    Error: DriveInstall must be run on X86_64 HOST platform. Detected aarch64 platform.

  5. I have verified that I am on aarch64 (not on X86_64)
    nvidia@tegra-ubuntu:~/Samuel$ uname -a
    Linux tegra-ubuntu 4.4.15-rt25-tegra #1 SMP PREEMPT RT Sat Feb 18 09:04:00 PST 2017 aarch64 aarch64 aarch64 GNU/Linux
    nvidia@tegra-ubuntu:~/Samuel$

I went through the nvidia forum to find an answer for resolving this issue. There were some people facing the same problem. However, I am unable to find convincing and proper steps to resolve this issue. This is because, most of the discussion were focusing on JetPack not DriveInstall 4.1.8.0L

Would you please throw some light on this? (Like what are the steps i need to perform to flash the image and so on)

Appreciate your help.

Thanks
Sam

Now I figured it out. However, now i am hitting another issue. I got the following message while upgrading to DriveInstall 4.1.8.0L

"Following msg appears during driveinstall upgrade.
The below components may require additional user input.

  • OSS and NV packages
  • DPX packages "

I noted down this message and continued my install. The Driveinstall 4.1.8.0 Linux component Manager showed me the following progress on the terminal.

Uncompressing vibrante-t186ref-linux-4.1.8.0-9408590…


Installing vibrante-t186ref-linux root filesystem

Now installing sample_fs_xenial_desktop_arm64.tbz2 to ./vibrante-t186ref-linux/targetfs
Unpacking /home/sjeyaseelan/Downloads/DRIVEINSTALL/VibranteSDK/vibrante-t186ref-linux/targetfs-pkgs/minimal/sample_fs_xenial_desktop_arm64.tbz2 to ./vibrante-t186ref-linux/targetfs.
[sudo] password for sjeyaseelan:

Then I entered my sudo password and hit return. But after this, I am not seeing any progress either on the terminal nor on the directory that I specified where files to be built.

The directory shows me the following files. There were no changes made either on the time-stamp or size of the files. I am not sure, this got stuck or working in the background?

sjeyaseelan@sjeyaseelan-ubuntu:~/Downloads/DRIVEINSTALL_DOWNLOAD$ ls -lrt
total 10661464
-rwxrwxr-x 1 sjeyaseelan sjeyaseelan 133424175 Aug 31 12:24 DriveInstall_4.1.8.0L_SDK_b43.run
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 8808523 Aug 31 12:36 DriveInstall_4.1.8.0L-Documentation-SDK.zip
-rwxr-xr-x 1 sjeyaseelan sjeyaseelan 31594145 Aug 31 12:36 vibrante-t186ref-foundation-4.1.8.0-9387945-p2379specific.run
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 598222176 Aug 31 12:40 vibrante-t186ref-4.1.8.0-aarch64-driveworks-v0.3.422.run
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 1073741824 Aug 31 12:42 vibrante-t186ref-foundation-4.1.8.0-9387945.sdk.7z.001
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 1073741824 Aug 31 12:42 vibrante-t186ref-linux-4.1.8.0-9408590-sdk.7z.001
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 249395710 Aug 31 12:42 nv-gie-repo-ubuntu1404-ga-cuda8.0-trt2.1-20170614_1-1_amd64.deb
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 7349554 Aug 31 12:43 cmake_3.2-3_amd64.deb
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 763386824 Aug 31 12:44 driveworks-v0.3.422-linux-amd64-ubuntu1404.deb
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 113833397 Aug 31 12:44 vibrante-t186ref-foundation-4.1.8.0-9387945.sdk.7z.002
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 161782382 Aug 31 12:46 driveworks-v0.3.422-vibrante-t186ref-4.1.8.0-cross.deb
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 3003016 Aug 31 12:46 sherlock-v0.3.0-linux-amd64-ubuntu1404.deb
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 47530653 Aug 31 12:46 vibrante-t186ref-linux-4.1.8.0-9408590-dpx.run
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 986116 Aug 31 12:46 vibrante-t186ref-linux-4.1.8.0-9408590-tegra2aurix_updater.run
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 602877 Aug 31 12:46 Start_NVIDIA_Docs_SDK.zip
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 121538555 Aug 31 12:46 vibrante-t186ref-vwx-1.6.0.224n.run
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 1073741824 Aug 31 12:47 vibrante-t186ref-linux-4.1.8.0-9408590-sdk.7z.002
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 1073741824 Aug 31 12:49 vibrante-t186ref-linux-4.1.8.0-9408590-sdk.7z.003
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 1073741824 Aug 31 12:52 vibrante-t186ref-linux-4.1.8.0-9408590-sdk.7z.004
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 1073741824 Aug 31 12:55 vibrante-t186ref-linux-4.1.8.0-9408590-sdk.7z.005
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 1073741824 Aug 31 12:57 vibrante-t186ref-linux-4.1.8.0-9408590-sdk.7z.006
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 1073741824 Aug 31 13:00 vibrante-t186ref-linux-4.1.8.0-9408590-sdk.7z.007
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 85687508 Aug 31 13:01 vibrante-t186ref-linux-4.1.8.0-9408590-sdk.7z.008
drwxrwxr-x 2 sjeyaseelan sjeyaseelan 4096 Aug 31 15:17 tmp
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 198 Aug 31 15:27 manifest.json
-rw-rw-r-- 1 sjeyaseelan sjeyaseelan 151570 Aug 31 15:27 repository.json
sjeyaseelan@sjeyaseelan-ubuntu:~/Downloads/DRIVEINSTALL_DOWNLOAD$ ls -lrt tmp
total 36
-r-------- 1 sjeyaseelan sjeyaseelan 3889 Aug 31 12:33 com.nvidia.docs.jetpack.sdk_nvidia.png
-r-------- 1 sjeyaseelan sjeyaseelan 3889 Aug 31 14:15 com.nvidia.v4l.vibrante_nvidia.png
-r-------- 1 sjeyaseelan sjeyaseelan 7185 Aug 31 14:52 com.nvidia.cuda.target_CUDA_icon64.png
-r-------- 1 sjeyaseelan sjeyaseelan 3889 Aug 31 14:53 com.nvidia.v4l.dpx_nvidia.png
-r-------- 1 sjeyaseelan sjeyaseelan 3889 Aug 31 15:12 com.nvidia.v4l.7z.sdk_nvidia.png
-r-------- 1 sjeyaseelan sjeyaseelan 3889 Aug 31 15:16 com.nvidia.gie.target_nvidia.png
-r-------- 1 sjeyaseelan sjeyaseelan 3889 Aug 31 15:17 com.nvidia.v4l.aurix_firmware_updater_nvidia.png
-r-------- 1 sjeyaseelan sjeyaseelan 3889 Aug 31 15:17 com.nvidia.driveworks.target_nvidia.png
sjeyaseelan@sjeyaseelan-ubuntu:~/Downloads/DRIVEINSTALL_DOWNLOAD$

How do I know either the Driveinstall 4.1.8.0 component manager got stuck or it is still working in the background (like unpacking sample_fs_xenial_desktop_arm64.tbz2 still in progress)?

Dear SamJey,

Please follow the DRIVEInstall installation instructions to complete the install.
https://developer.nvidia.com/drive/driveinstall

And please refer to below link, you can download getting-started-with-drivepx2 file.

All issues are resolved. Let me summarize the issues I found during install and how I solved them.

  1. During install, you will be prompted to enter the password. I guess, the password is associated with some timeout value. After the timeout, if you enter the password, the system does not throw any informative log to the screen. The user does not know whether the password is accepted or rejected. In this case, you need to start the install again.
    (BTW - I started install and went out for lunch, then I came back I entered the password and waited for around 2 hours thinking the system took my password with an assumption that system is processing the install in the background)

  2. Never use Virtual machine for flashing the image. It is mandatory to use physical host machine

  3. Drive PX 2 is not compatible with Ubuntu 16.04 version of the host machine. We need to use 14.04 version of the physical host machine for install and flash. (not sure why nvidia doc pages show they support 16.04 host machine which is contradicting to me)

Aurix DPX2-EB-Aurix-1.03.00 is compatible with Beta 3.0(NVIDIA DRIVE 4.1.8.0) ?

Dear SamJey,

No, could you update Aurix FW for Beta 3.0? Thanks.

Thanks Steve.