Revit Hardware Acceleration disabled after VDA installation

Hello, I am setting up a new XenApp/XenDesktop deployment (first timer) and am running into issues. While setting up the master image using the GRID K260Q vGPU, hardware acceleration is enabled and functioning in Revit and AutoCAD. Both programs are aware of the card and there is no issue. As soon as I install the VDA component on the master image, it breaks this functionality in Revit. It still shows enabled in AutoCAD, but in Revit it says: “Revit detects an unsupported video card ‘’ and driver ‘’.”. When I look in the Device manager it shows the correct GRID card. I have tried full GPU passthrough with the same issue. I have tried installing VDA as both Power controlled and not, no difference. Does anyone know what is causing this or what I am doing wrong?

Our system is as follows:

Dell R720
2 x GRID K2 cards
XenServer 6.5 (all current updates)
XenDesktop/XenApp 7.6

Revit 2015, 2016
AutoCAD 2015, 2016

You should install the VDA before any applications.

Try that order then see how it behaves.