RGMII phy-mode

Hallo,
we have a custom carrier board for the AGX orin on which the RGMII interface is connected to a microchip switch. In the standard configuration the switch is in phy-mode rgmii-rxid. The change in the devicetree seems to have no effect. Is it possible to activate the TX clock delay in the MAC?
Best regards
Lennart

Hi,
It looks like we don’t list the DT entry in adaptation guide:
Jetson AGX Orin Platform Adaptation and Bring-Up — Jetson Linux Developer Guide documentation

Will check with our teams if we support it and get back to you.

Hi,
We have checked with our team and confirmed tx and rx clock delay are not supported and has to be provided by the phy.
The Ethernet PHY on the customer carrier board should have the RX and TX delays enabled on the PHY. Could you check this?

Hi,
we are using a microchip KSZ9563 and you can only enable the tx delay via I2C and on our Board it is connected via MDIO. At the moment I am trying to get it running via “I2C-GPIO” driver. Now I can set the tx delay via “i2cset” and I get a working Ethernet connection but the KSZ9563 Linux driver does not work so far.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.