RHEL 5.x 64 bit SDK make problems Seen this same problem in forums but solutions dont work for me

Hello all,

So I have spent some time in the forums looking for topics with similar problems as me. It seems that a lot of people have had problems with getting the SDK/tool kit to work with some of their systems. I have tried every ‘solution’ I have seen, but the commands have not worked for me. It is possible that this is true because in the other cases a different distribution of linux was used. Specifically, I installed the SDK and toolkit in the default places following the ‘Getting Started’ pdf file. I would type make in the NVIDIA_CUDA_SDK directory and the first problem I had was with the build not being able to find the glu.h, gl.h files. Following advice on the forums I was able to fix this by running

[codebox]sudo yum install libxmu-dev libxi-dev[/codebox]

and I believe I ran more than just these. I seemed to have fixed the first problem, but now when I try to make the file I get the error:

[codebox]make -C projects/bitonic/

make[1]: Entering directory `/u/brose/NVIDIA_CUDA_SDK/projects/bitonic’

make[1]: Leaving directory `/u/brose/NVIDIA_CUDA_SDK/projects/bitonic’

make -C projects/marchingCubes/

make[1]: Entering directory `/u/brose/NVIDIA_CUDA_SDK/projects/marchingCubes’

/usr/bin/ld: cannot find -lXi

collect2: ld returned 1 exit status


I have seen this error in other threads and it seems that maybe there is an incompatability issue? Any advice as to what is wrong and how I can fix it would be appreciated. P.S. If you can’t tell I am very new to linux.

You need to install the X11 input extensions. Probably the packages you want to install are libXi and libXi-dev.

I have tried this. It says I already have them installed I believe.

[codebox][brose@ucla-grendel ~/NVIDIA_CUDA_SDK]$ sudo yum install libXi libXi-dev


Loaded plugins: rhnplugin, security

Setting up Install Process

Parsing package install arguments

Package libXi-1.0.1-3.1.x86_64 already installed and latest version

Package libXi-1.0.1-3.1.i386 already installed and latest version

No package libXi-dev available.

Nothing to do


OK so you will need to find where it is installed and update the SDK common.inc to find it, although that is strange, because on my Centos 5 boxes it is just in /usr/lib and /usr/lib64 and the SDK finds it without a problem.

Thanks a lot… These instructions was really helpful for me (as a new user!)…

Thanks a lot… These instructions was really helpful for me (as a new user!)…