RHEL 7.3 with HPE 545 QSFP

Product Name ProLiant DL180 Gen9

HP Infiniband FDR 2-port 545QSFP Adapter

kernel: mlx5_core 0000:06:00.0: firmware version: 10.10.5052

This adapter was working on RHEL 7.1 and failed after upgrade to 7.3 RedHat support advised:


I find there is at least one other issue reported so far with the 7.3 kernel and the mlx5 modules. It appears the mlx5 module requires a firmware revision of 12.14 or higher. The logging from the yuma host shows a 10.x series firmware. kernel oops with mlx5 when upgrading to RHEL 7.3 https://access.redhat.com/solutions/2694091 https://access.redhat.com/solutions/2694091 The findings in the article above are preliminary but it does hint at issues with the older firmware revision. Definitely reach out to your hardware vendor to confirm whether a newer 12.x series firmware is available for your card and if that causes the issue to resolve itself.


Anybody have any experience with this? What is involved upgrading the firmware? Where do I get it? Mellanox web site? HPE? Do I need to go back to RHEL 7.1 or 7.2 to run the firmware upgrade?

Regards,

Rich

Hi Rich Pope https://community.mellanox.com/s/profile/0051T000008EaYZQA0 ,

please take a look at http://www.mellanox.com/page/firmware_table_hpe?mtag=oem_firmware_download http://www.mellanox.com/page/firmware_table_hpe?mtag=oem_firmware_download

Updating Firmware for HPE Enterprise Branded Adapters

http://www.mellanox.com/mymellanox-app/ http://www.mellanox.com/mymellanox-app/

HPE Enterprise and Mellanox have had a successful partnership for over a decade. HPE support engineers worldwide are trained on Mellanox products and handle level 1 and level 2 support calls. This enables customers to have just one number to call if support is needed. Mellanox products and HPE hardware give customers the best in class products and support. The partnership between Mellanox and HPE provides customers an end-to-end solution for HPC, Cloud, and Storage needs.

Please perform the procedure described below to update the firmware on your HPE adapter card.

  1. Visit www.hpe.com http://www.hpe.com/ .

  2. Click Support and select HPE Servers, Storage and Networking (under Product Support).

  3. Enter the HPE saleable product name or part number in the search engine.

    [Example: 649282-B21]

  4. Select the link for the device.

  5. Choose your product’s Operating System(s) from the displayed list to download the published drivers and firmware.

Note: Each posting has a completed worked example showing how to query and upgrade.

Please do not hesitate to contact me if you have any further questions.

Talat.

Thank you, Talat.

At the time, the Linux admin guys werwe traveling and did not have

access to HPE contact info. I tried contacting NonStop support (which I

deal with all the time) but they of course didn’t support the PC. But

nobody could get me any contact info and it was well hidden online.

Eventually I found a US number and after a long search she gave me a

German number, but of course they wee closed for the weekend by then.

HPE’s support web site would not accept any of the part numbers of

serial numebrs that I had. Mellanox’s support site did not list the HPE

part numbers - it looked like HPE had different part numbers from

Mellanox cards. I also could not find any instructions on firmware

upgrade, nor if we would be able to perform the upgrade while running

RHEL 7.3. I also figured that Mellanox would not provide any direct

support since we were an HPE customer. I don’t have a lot of use for

“OEM” arrangements where the OEM doesn’t add any value or change

anything, but merely insinuates iteself between the end user and the

actual manufacturer - what I call “value subtracted” or

“lose-lose-lose”.

We werew able to backboot to RHEL 7.1 kernel so I could continue with IB

work over the weekend. This morning (European time) the Linux admin

noticed that RedHat support has a typo in the version number. He was

able to get the required firmware from HPE website and reflash (I don’t

know the details) the HPE/Mellanox card. The Mellanox works on RHEL 7.3

now. We still have a problem with LD_PRELOAD libvma, which was the

reason for 7.3 upgrade, but we just reported that to RedHat support

(which is really first rate).

So, tempest in a teapot. Unfortunately came at the worst possible time

when everyone - including this forum - was offline for the weekend.