RHEL OPtimus Driver

We are experiencing some trouble during the integration of a Lenovo P71 including NVIDIA Quadro MX2200 on RHEL 7.7 Operating System and we want to know what kind of support can be afford to us.

We need, for our customers, to intergrated a custom RHEL 7.7 operating system on a Lenovo P71 machine (20HL reference with a Core i7-7820HQ processor). We manage to install the operating system on the computer, however the integration of the NVIDIA Quadro MX2200 card is not optimal, even not functionnal at all due to Optimus drivers.

RHEL seems to affirm that Lenovo P71 (20HK) with intel Xeon processor is supported with nvidia drivers.

We opened many ticket in attention of RHEL support team (Support / Bug Access Denied ) to solve this problem. By the way, REDHAT team never manage to solve our problem and neither external Output works, nor performance are good (decrease by 10 comparing to attended performance). They also decided that a won’t fix issue should finally be the results of our tickets.

Nevertheless, I need to deliver an important customer, and I can obviously not deliver him this laptop with such bad performance regarding to the configuration of the machine.

I saw NVIDIA has many version of the drivers for the QUADRO M2200 series (including Linux 64 bits AMD64/EM64T , but this does not seems to work with our laptop configuration.

Can you tell me if NVIDIA is able to develop specific drivers for this kind of configuration ? how should this be done (quotation of the development to command / …)

For RHEL 7, you should install the drivers from a repo like rpmfusion, don’t use the runfile.
and then set up the config for the desired state:

We did the tests on a laptop, after installing a RHEL OS:

  • Installation of kernel 3.10.0-1127, coming from a RHEL7.8.
    The kernel installs correctly. The system has no difficulty starting on this version.
  • Installation of NVIDIA 440.100 drivers, available. The drivers are installed. The / var / log / messages file clearly indicates that the 440.100 kernel module is loaded at boot.

If the laptop is in Hybrid mode:

  • The message on mode selection at start-up (video mode 0x34d does not exist) still exists. This is normal since at this time of boot, we remain on the Intel card.

  • If we configure X11 to add the PrimaryGPU option for the NVIDIA driver, in order to force X11 to use the card → X11 does not start. The behavior is identical to the old 430.40 drivers

  • If we keep the X11 configuration and that we set the environment to use the PRIME render offload, as indicated in the rpm fusion documents → the render does not seem to change. Worse, it causes X11 to crash just by running glxgears.

  • The addition of the AllowNVIDIAGPUScreens option, which strangely is not present in the X11 conf, improves things a bit. The nvidia card is well recognized (nvidia-settings works and finds the card well). On the other hand, the offload is still not good (glxinfo gives an X11 error at launch)

We did the same test with a RHEL 7.9 OS by installing nvidia 450.66 driver from rpmfusion with kernel 3.10.0-1127 (instead of 3.10.0-1160 from RHEL 7.9), we followed the rpmfusion doc to configure X11 and to use the PRIME render offload and we finally observe the same behavior as described in discreet mode, X11 crashes the system on startup…and the laptop is not working…

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

here are the lognvidia-bug-report.no_render_offload.log.gz (639.5 KB) nvidia-bug-report.render_offload.log.gz (657.1 KB)

The problem is the Xserver version, render offload requires at least xorg 1.20.6, installed is 1.20.4.

Actually package 1.20.6 seems to be only available for RHEL 8.x, and we are running under an RHEL 7.7 without possibility to upgrade to RHEL 8.x ?

Will this package be running on RHEL 7.7 ?

Mixing packages like that should be avoided, it’ll break dependencies.
So with a rhel 7 install, you will be limited to a PrimaryGPU setup. Please provide a nvidia-bug-report.log from that setup.

Ok, regarding to your response, I don’t understand what to change to limit my configuration to a primaryGPU setup ?

Please set the primarygpu option like mentioned in the rpmfusion optimus doc.
You might also have to create config files for gnome:
create two files optimus.desktop in /etc/xdg/autostart/ and /usr/share/gdm/greeter/autostart/ containing

[Desktop Entry]
Exec=sh -c "xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto"