RHEL7 beta

[s]I’m trying out the new RHEL beta and trying to install NVIDIA-Linux-x86_64-331.20. I was able to build the module with --no-unified-memory, but after completing the setup, X segfaults with the following error:

This server has a video driver ABI version of 15.0 that is not supported by this NVIDIA driver.[/s]

Edit:

Got the Nvidia driver running properly under RHEL7 beta with the following driver -

http://www.nvidia.co.uk/download/driverResults.aspx/71444/en-uk

Version: 304.1170
Release Date: 2013.12.11

I believe 319.76 also supports X.org 15 if you don’t need the legacy driver.

Thanks for the suggestion, I’ll try that version as well. Things are working great so far.

319.76 works great, huge speed improvement on my GTX460M.

319.76 it does not work in RHEL7 beta [GeForce G102M]

Does your computer have Optimus?

You need to disable selinux as it blocks nvidia from starting,I’m using 304.117 without issue.

thanks,after exam ,I will try it again

My computer does not have Optimus

Yes,319.76 can run ok! but, X window collapse Occasionally! I thingk There are some problems with xorg …

Yeah, I didn’t know leigh123linux recommends disabling selinux! Maybe it’s not the same leigh as on fedoraforum.

Anyway, I’m not exactly sure what specific part SELinux blocks that would cause failure to start X server (maybe writeable memory?) with nvidia driver, but there’s a lot of different ways/options to handle SELinux without simply disabling it. As the first step, take a look at the xserver_selinux (8) manual page, which has a lot of pertinent information.

If you believe that SELinux is preventing X server to start, check your logs. This is an example from my system:

# grep -i selinux /var/log/Xorg.*
/var/log/Xorg.0.log:[  2260.262] (II) SELinux: Disabled by boolean
/var/log/Xorg.9.log:[    28.407] Initializing built-in extension SELinux
/var/log/Xorg.9.log:[    28.912] (II) SELinux: Disabled by boolean
/var/log/Xorg.9.log.old:[     9.398] Initializing built-in extension SELinux
/var/log/Xorg.9.log.old:[     9.955] (II) SELinux: Disabled by boolean

Then, check the relevant Booleans. As I said, they are listed in detail and in greater number within the manpages ; as a simple example:

# getsebool -a |grep -i xserver
virt_use_xserver --> off
xserver_clients_write_xshm --> off
xserver_execmem --> off
xserver_object_manager --> off

Then, if you want to change the boolean permanently, do:

# setsebool -P xserver_execmem 1

0 = OFF
1 = ON