RMA Jetson Nano wont boot up. However green LED works.

I’ve just received the RMA unit, however unlike my old Jetson Nano (where it booted up with no problems), this unit fails to display via HDMI output. As mentioned in the title, only the green LED works. I’ve tried to troubleshoot the following problem to no avail, such as:

  1. Formatting and and flashing the micro SD card manually with terminal, and with Etcher
  2. Swapping different micro SD cards.
  3. Swapping out different HDMI and Display port cables and monitors
  4. Changing the power adapter 5v/2A micro usb and 5v/4A barrel plug, as well as the cables.

Since NVIDIA doesn’t ship their RMA units to Japan, I had paid quite a sum of money to ship the item and had it returned via a forwarder. RMA’ing the unit again is not an option

I would appreciate it if you can further advise me in this issue.

Hi,

Could you try connecting a UART cable to it and look at what is going on at the board? Here is a quick post about how to do it for your convenience:

Best Regards,

Yes, please share the kernel log with us. Thanks.

Thank you for the reply. I will share it the logs once I recieved the UTL cable from amazon.

Hi,

Finally got my hands on a TTL cable. Heres the logs from minicom.

[0000.126] [TegraBoot] (version 00.00.2018.01-l4t-33e7fa82)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.152] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x1032e2
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.217] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.223] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.260] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.265] Non secure mode, and RB not enabled.
[0000.272] Invalid GPT Partition
[0000.287] Using BFS PT to query partitions
[0000.291] failed to load NvTbootTbootCpu from (2:0)
[0000.296] re-load NvTbootTbootCpu from (4:0)
[0000.300] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.310] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.317] Number of retries left 4
[0000.320] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.330] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.337] Number of retries left 3
[0000.340] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.350] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.357] Number of retries left 2
[0000.360] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.370] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.376] Number of retries left 1
[0000.380] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.390] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.396] Number of retries left 0
[0000.399] Send command failed with 0x3
[0000.403] CMD8 send failed. Retrying CMD0/CMD8 (2)...
[0000.408] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.418] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.425] Number of retries left 4
[0000.428] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.438] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.444] Number of retries left 3
[0000.448] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.458] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.464] Number of retries left 2
[0000.468] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.478] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.484] Number of retries left 1
[0000.487] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.498] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.504] Number of retries left 0
[0000.507] Send command failed with 0x3
[0000.511] CMD8 send failed. Retrying CMD0/CMD8 (1)...
[0000.516] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.526] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.532] Number of retries left 4
[0000.536] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.546] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.552] Number of retries left 3
[0000.555] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.565] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.572] Number of retries left 2
[0000.575] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.585] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.592] Number of retries left 1
[0000.595] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.605] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.612] Number of retries left 0
[0000.615] Send command failed with 0x3
[0000.618] CMD8 send failed. Retrying CMD0/CMD8 (0)...
[0000.623] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.633] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.640] Number of retries left 4
[0000.643] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.653] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.660] Number of retries left 3
[0000.663] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.673] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.680] Number of retries left 2
[0000.683] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.693] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.699] Number of retries left 1
[0000.703] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.713] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.719] Number of retries left 0
[0000.722] Send command failed with 0x3
[0000.726] CMD55 send failed with error 0x3 in SdIdentifyCard func at 1846 lin
[0000.733] Identify card failed with 0x3
[0000.737] SdIdentifyCard has failed with error 0x3 in NvTbootSdmmcInit func a
[0000.744] Sdmmc Init failed with 0x3 error
[0000.749] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.759] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.765] Number of retries left 4
[0000.768] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.779] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.785] Number of retries left 3
[0000.788] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.798] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.805] Number of retries left 2
[0000.808] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.818] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.825] Number of retries left 1
[0000.828] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.838] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.845] Number of retries left 0
[0000.848] Send command failed with 0x3
[0000.851] CMD8 send failed. Retrying CMD0/CMD8 (2)...
[0000.856] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.866] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.873] Number of retries left 4
[0000.876] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.886] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.893] Number of retries left 3
[0000.896] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.906] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.913] Number of retries left 2
[0000.916] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.926] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.932] Number of retries left 1
[0000.936] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.946] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.952] Number of retries left 0
[0000.955] Send command failed with 0x3
[0000.959] CMD8 send failed. Retrying CMD0/CMD8 (1)...
[0000.964] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.974] Command complete wait failed with error 0x3 Interrupt 0x18000
[0000.981] Number of retries left 4
[0000.984] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0000.994] Command complete wait failed with error 0x3 Interrupt 0x18001
[0001.000] Number of retries left 3
[0001.004] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0001.014] Command complete wait failed with error 0x3 Interrupt 0x18001
[0001.020] Number of retries left 2
[0001.024] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0001.034] Command complete wait failed with error 0x3 Interrupt 0x18001
[0001.040] Number of retries left 1
[0001.043] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0001.054] Command complete wait failed with error 0x3 Interrupt 0x18000
[0001.060] Number of retries left 0
[0001.063] Send command failed with 0x3
[0001.067] CMD8 send failed. Retrying CMD0/CMD8 (0)...
[0001.072] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0001.082] Command complete wait failed with error 0x3 Interrupt 0x18000
[0001.088] Number of retries left 4
[0001.092] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0001.102] Command complete wait failed with error 0x3 Interrupt 0x18001
[0001.108] Number of retries left 3
[0001.111] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0001.122] Command complete wait failed with error 0x3 Interrupt 0x18000
[0001.128] Number of retries left 2
[0001.131] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0001.141] Command complete wait failed with error 0x3 Interrupt 0x18000
[0001.148] Number of retries left 1
[0001.151] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWa
[0001.161] Command complete wait failed with error 0x3 Interrupt 0x18001
[0001.168] Number of retries left 0
[0001.171] Send command failed with 0x3
[0001.174] CMD55 send failed with error 0x3 in SdIdentifyCard func at 1846 lin
[0001.181] Identify card failed with 0x3
[0001.185] SdIdentifyCard has failed with error 0x3 in NvTbootSdmmcInit func a
[0001.193] Sdmmc Init failed with 0x3 error
[0001.197] Error is 3

Bump

Hi, does anyone have any insight as to what is wrong with the jetson nano?

Looks the first stage boot loader can’t read your sd card so its not progressing. So either the card is a problem or the image hasn’t been flashed correctly.

You should see something like this where the sd card partition is detected:

[0000.296] re-load NvTbootTbootCpu from (4:0)
[0000.917] Csd NumOfBlocks=123473920
[0000.975] Using GPT Primary to query partitions
[0000.983] Loading Tboot-CPU binary
[0001.358] Verifying TBC in OdmNonSecureSBK mode
[0001.368] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0001.375] Bootloader downloaded successfully.
[0001.379] Downloaded Tboot-CPU binary to 0xa0000258

Do you know how to fix this? This wasn’t an issue with my last Jetson nano, and I’ve already used a couple of micro sad cards already

Update: I’ve been trying to use sdk manager to flash my sd card. After a failed attempt to flash the program, It seems my computer can no longer detect the board, using the command ‘lsusb’. I’ve already switched multiple micro usb cables to no avail

Anyone know as to why?

Hi, looks like SD card reading fail. If you have hw experience, you can check the power supply and signal quality of SD part. Otherwise you will have to send it RMA again.

Thank you for the reply Trumany.

Do you have any resources, such as jetson hack, that show how to check the power supply and signal quality?

Alternatively, is it possible to boot from a USB, without a flashed sd card?

Kind regards,
Michael

To flash the SD card, use “dd” with a USB SDcard reader/writer, if possible.
“dd” in a terminal is a more reliable program than pretty much anything else in my experience!

So, download the image, and uncompress it if it’s compressed (so you have a .img file) and then simply overwrite the entire card:

sudo dd if=my-jetson-image0-file.img of=/dev/sdq bs=1M

/dev/sdq is the device that your SDcard is actually on – note, NOT one of the partitions (like /dev/sdq0 or /dev/sdq1) but the top-level disk device. You can see where the sdcard is by doing “ls /dev/sd*” before inserting the USB reader with the card in it, and then the same again afterwards, and see which device(s) show up.

Also, if you write a SDcard image, and then put that into the Jetson, you don’t need the USB cable/flashing setup – it should just boot straight from that image you wrote.

I

Is it possible to run this on a Mac? It’s difficult to set this up with Ubuntu

Mac does have some “UNIX-like” commands in common with Linux. If dd is available on a Mac, then it would work the same as from Linux (or any flavor of *NIX).

Yes, a Mac has “dd” (it’s basically a BSD UNIX flavor underneath) but I think it uses a different naming convention for what the SDcard device would be called – you’ll have to check the Mac documentation for getting the right name.

Thank you very much for the verification. I appreciate it.

Thank you for letting me know. I found that mac uses a small ‘m’ instead of the big ‘M’, as well as apostrophes for the directory. For example

sudo dd if='/<Add Directory>/jetson-image0-file.img' of=/dev/disk<add disk number> bs=1m

Furthermore my machine has an internal reader, so ive used the command below to find the type of dev/disk*.

diskutil list

I’ve also succesfully flashed my sd card using this command (as indicated below).

/jetson-nano-sd-r32.1.1-2019-05-31.img' of=/dev/disk2 bs=1m
12288+0 records in
12288+0 records out
12884901888 bytes transferred in 2914.225648 secs (4421381 bytes/sec)

Unfortunately the jetson nano still refuses to boot, and am now almost sure that Nvidia has sent me a unit, which has a defective SD card reader.

If you try flashing through SDK Manager that would highlight if the card can’t be detected by the boot loader.

Thank you for the reply.

I’ve tried to flash through SDK manager, and it gave alot of error messages. Furthermore, after this failure, the unit no longer shows up as usb device via the command ‘lsusb’ (micro usb) or ‘dmesg --follow’ (TTL cable).

Again this wasn’t an issue with my first jetson nano, which booted fine

Honestly, if i knew that I had to spend this amount of time and money dealing with this issue, i would’ve instead bought a coral edge board.

I recommend the Xavier if you prefer performance and low hassle over low cost.