RMA map is not working

Hello! See this:

It is a model that have ALB, NRM and RMA maps. I cannot see any effect in using this RMA map on my Create project on the imported ( converted during import from fbx ) USD object.

I have put the RMA.tga texture on my Reflectivity / Roughness map and in Metallic map.
Here is a jpg version on this RMA.tga texture:

Also the NRM.tga also just makes my helmet to look bad:

So I can only use the ALB texture. What is the deal, why?


You just have to set normal colorspace in dropdown to raw vs auto. We are looking for ways to make this automatic.

Thanks but this raw color space did not solved the odd looking normal map.

Do you mind sharing the USD and texture maps? If you do, is this happening on another software like Maya?

Sure, here:

Sorry I did not had time today to check this model in Cinema 4d, but I have made rendering with it and I saw that I had user at least the RMA channel too :)

Thanks for being patient. I noticed it is doing the same thing on 3dsMax image
Is it possible that the normal map needs to be updated?

Ok, I tried another pro model from CGtrader. This time the albedo, roughness and metallic maps worked fine:

But normal map was misbehaving again. Here is the orginal fbx and textures: