RMA Replacement for Jetson Nano 2GB

We ordered a Jetson Nano 2GB on April 7, 2021 from Amazon.ca
Recently it stopped working. It won’t boot at all. No signal from the HDMI port. But the green light comes on.
This happened suddenly, with no changes in any hardware or software configuration.
-We tried using different HMDI cables that we know work with other devices.
-We also tried different monitors & TVs that we know work.
-We also tried different power supplies that meet the recommended specs.
-We also tried different SD cards.
-We also tried reformatting the SD cards.
-We thoroughly examined the Jetson Nano printed circuit board to ensure it was clean.
-We tried running it in headless mode.
Nothing worked.
When we inserted the SD card, and power up the unit, the green light comes on, but nothing shows up on the screen. In fact, the monitor says “no signal”. No sign of life other than the green light.
I have contacted the Live Chat on Nvidia.com and spoke to Sangeeta, who directed me here.
I am very tech-savvy. And all evidence seems to point to a faulty unit. Could we please have a replacement as it is within the 1-year time frame. However, please note that there are only a matter of days before the 1-year term is up.


Looks like you didn’t try to most important one to confirm whether this is hardware or software issue.

  1. There is a QSPI flash on the jetson nano module, this one has the bootloader software. The reason why our board can directly plug in a sdcard and boot up is due to this software on this flash. However, if the software on this flash has something wrong, then no matter how many sdcard you replaces/re-formatting, it won’t save this bootloader software back.

  2. To save the case in (1), the only way is using sdkmanager. However, this requires to use x86_64 ubuntu 18.04 host and cannot be a VM.

  1. Most of boot up cases would be fixed by using sdkmanager.

  2. If you also want precise analysis from us, you need to dump the uart log. But since you want to check this fast, I would say flash with sdkmanger first.
    Jetson Nano Style - Serial Console - JetsonHacks

Hi WayneWWW,

You are right! I was wrong in thinking I tried everything. I followed your instructions, and it worked! Thank you for your help. It is much appreciated!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.