ROMOSS sense 8+ powerbank on jetson

Hi,

I just bought the sense 8+ powerbank ROMOSS.

First I powered my nano through micro B USB. It was fine until I missplaced the output of my powerbank to 3A 5V. Now I believe that the micro USB B port is dead or a component nearby (resistance, condo…).

So I bought a cable for the powerjack input. Unfortunately i can’t power it. The green led briefly switch on and off.

Technical param of ROMOSS : https://imgur.com/UsTzczt

I guess it should be 5V 4A but I thought it could be possible with 3A (4A MAX).

Thanks,

Me

Hi, generally the 5V 3A input will not cause board dead as the voltage is correct and current is drew as need. You can try DC jack if possible to check if board can be on.

First thanks for reply,

Unfortunately the mirco USB-C is dead during powering with my powerbank. It started lagging then I couldn’t use it from anywhere.
When I try to connect the Nano to my USB charging station the station just shutdown (short circuit protection maybe).

I bought it from Seeed studio and I don’t think I can’t get refunded.

I believe also that the nano killed one of my micro USB charger after that. I wouldn’t be surprise if there is a short circuit.

Furthermore if I plug my AC/DC adaptor 5V 4A into the powerjack it works.
However if I use the powerbank fit+ (5V 3A) on the jack, the green led blink one time and that’s all.
Here’s the video: https://vimeo.com/383051406
Maybe the powerbank doesn’t actually deliver 3A or it has something to do with circuit protection.

The thing is it worked before on micro B USB until it died one day later or smth.

You can run RMA process for it: https://devtalk.nvidia.com/default/topic/998129/jetson-tx2/links-to-jetson-tx2-resources-and-wiki/post/5101960/#5101960

Hi i come back to say I did the RMA process and then sent me back a new one that should works now. Thank you.

I am trying now to turn on with my old sd card that worked on my old jetson nano.
But it seems that it doesn’t boot up (black screen).

Do I have to reflash and loose everything?

Thank you again.