RTC on Jetson TX2 Custom Carrier Board - Custom Voltage & Current

VDD_RTC (pin A50) on our custom Jetson TX2 carrier board is outputting 0V. The RTC capacitor selected for the custom board is the same as on the Developer Kit Carrier Board (P2597), where it is outputting 2.4V.

The EEPROM chip is not on the custom board, so we had to make some changes to the power tree (Tegra_Linux_Driver_Package_TX2_Adaptation_Guide pg.10) to power the USB 3.0 bus. Do we need to do something similar for the RTC power?

For reference, we are using lane mapping configuration #2, and the CHARGER_PRESENTn pin is grounded for auto power-on.
We are using L4T version 28.1.

Hi,
Please check https://elinux.org/Jetson/TX2_USB#Patching_the_DTS

USB config #2 is same as developer kit carrier board, but most custom boards do not have tca9539 and you have to apply the patch.

Hi Dane,

Thank you for your reply. We have already implemented the referenced DTS patch to get USB 3.0 working. Can you please explain how the TCA9539 I/O expander plays into getting the VDD_RTC pin to output voltage?

If you were referring to the USB Lane Mapping section of that wiki link, the Jetson we have on the dev kit board displays the three messages in dmesg, and that is where the capacitor is charging correctly from VDD_RTC pin A50. On our custom board, we do not see these dmesg logs, and the capacitor is not charging. Does this have an impact on the VDD_RTC pin A50 outputting voltage?

Hi,
Sorry we are a bit confused. Do you mean if you apply USB lane mapping to device tree, VDD_RTC pin does not output voltage. If you don’t apply USB lane mapping, VDD_RTC pin works normally?

VDD_RTC should be independent of USB lane mapping, but somehow it seems related from your previous comment…

Our problem is that VDD_RTC has never outputted power on our custom board, and we don’t know why.

I asked the question about the USB Lane Mapping because I was trying to figure out how the link you provided was relevant to our VDD_RTC question.

We had an issue earlier where USB 3.0 was not outputting power on our custom board. To fix this, we had to patch the DTS like the link you gave in post #2. While trying to troubleshoot our VDD_RTC power issue, we thought that the solution might be similar to the USB 3.0 power issue.

To give you more information about our custom board, I included that we’re using lane mapping configuration #2, the CHARGER_PRESENTn pin is grounded for auto power-on, and we are using L4T version 28.1. Also, our custom carrier board does not have the ‘Carrier Board Config’ EEPROM chip (designator U11 on P2597).

I don’t know if the USB 3.0 power issue (that we already resolved) or any of the information above is relevant to the VDD_RTC issue. I was just trying to provide enough context.

So, with or without all the above information, our issue is this:
We observe VDD_RTC charging the capacitor when the Jetson is on the Developer Kit Carrier Board (P2597), but when we power everything down, move the Jetson to our custom carrier board, and power everything back on, we do not observe VDD_RTC charging the capacitor. The capacitors on the custom board and developer kit board are the same.

Hi,
VDD_RTC(A50) directly connects to MAx77620 pad BBATT. Could you check if BBATT is powered up on the custom board?

Please also check https://elinux.org/Jetson_TX1/FAQ
Design of A50 is identical on TX1 and TX2.

Thanks! We figured out it was a hardware issue and the capacitor was getting shorted.

I’m now having trouble getting the voltage to be set higher than 2.4 volts. From looking at the link you sent, I looked up where “maxim,backup-battery-charging-voltage = <3000000>;” is in our source, and it said " status = “disabled” ". I would assume that the voltage setting should allow the capacitor to charge to 3 volts as it is set, if status is changed to “enabled” or “okay”. I tried both and neither of these worked.
Ideally, we would like to set the voltage to 3.3V.

How can I get A 50 charging our capacitor to 3.3V?

Thanks

Hi,
The driver is at

kernel\kernel-4.4\drivers\mfd\max77620.c

You should change the device tree accordingly. You may check how the driver parses the device tree or try to get datasheet through Maxim.

The patches in the below post link fixed my problem. With these patches I can now customize the voltage and current for RTC in /usr/src/hardware/nvidia/platform/t18x/common/kernel-dts/t18x-common-platforms/tegra186-quill-spmic-p3310-1000-a00-00.dtsi

https://devtalk.nvidia.com/default/topic/905857/jetson-tx1/vdd_rtc-function-on-tx1-som/post/5225267/#5225267