Rtcwake does not wake after Jetson Nano emmc went into mem state

Hi

I am using Jetson Nano emmc version with Nvidia development board and trying to save power with rtcwake function.

I tried the commands below to make jetson nano sleep and wake up after 10 sec.
sudo rtcwake -v -u -s 10 -m mem
The jetson nano went into mem and woke up again after 10 sec. However, it went back to sleep again (the LED turned off and I couldn’t ping it anymore) after a few seconds and never woke up.
I will need to power cycle the unit to wake it up again. How do I make it stay waking up after the mem state?

Any input is appreciated.

hello YiCL,

please check developer guide, Chipset Power States for the supported power states.
you should refer to the available wake sources to awake Jetson from the deep sleep.
thanks

Hi JerryChang,

I issued the commands below.
sudo bash -c “echo date '+%s' -d '+ 20 seconds' > /sys/class/rtc/rtc0/wakealarm”

and tried both way to make my board goes into deep sleep
sudo systemctl suspend
$ sudo bash -c “echo mem > /sys/power/state”

However, I am still having similar issue. My Jetson Nano went into deep sleep mode and could not wake up again. I have tested 2 development board and 2 Jetson Nano emmc version. They all have the same behaviour. Is there any other way I can make this works?

Thanks.

hello YiCL,

please also share which JetPack release version you’re working with.
for example, $ cat /etc/nv_tegra_release

Hi JerrChang,
with cat /etc/nv_tegra_release, I got

R32 (release), REVISION: 5.1, GCID: 26202423, BOARD: t210ref, EABI: aarch64, DATE: Fri Feb 19 16:45:52 UTC 2021

I did more tests and realised sometimes sudo bash -c “echo date ‘+%s’ -d ‘+ 20 seconds’ > /sys/class/rtc/rtc0/wakealarm”
and sudo systemctl suspend worked as expected. However, sometimes the Jetson could not wake up.

Please let me know if there is anyplace I would need to modify to make sleep and wake up stable.

hello YiCL,

may I know the failure-rate.
could you please also setup serial console to gather bootloader logs when it’s not wake-up.
thanks

HI I could not replicate the error again. Now the wakealarm works as expected. Thanks for your help.