RTP stream slows down at each keyframe

I have this:

gst-launch-1.0 -e v4l2src do-timestamp=true device=/dev/video0 ! video/x-raw,format=NV12,width=1280,height=720,framerate=30/1 ! nvvidconv ! 'video/x-raw(memory:NVMM),format=RGBA' ! nvvidconv ! nvv4l2h265enc bitrate=5000000 insert-sps-pps=true insert-vui=true insert-aud=true iframeinterval=60 ! rtph265pay mtu=1400 ! udpsink host=xdomain.com port=9999 sync=false async=false

gst-launch-1.0 udpsrc port=9999 ! application/x-rtp,encoding-name=H265,payload=96 ! rtph265depay ! h265parse ! queue ! avdec_h265 ! autovideosink sync=false

I have noticed that every time the keyframe is sent, there is a small delay in the video.

Is there a way to prevent this from happening?

Hi,
We suggest try this setup:
Random blockiness in the picture RTSP server-client -Jetson TX2 - #5 by DaneLLL

Generally IDR/I frames have larger size. Setting virtual buffer size can reduce some gap between IDR/I and P frames.

And can enable this property and try:

  EnableTwopassCBR    : Enable two pass CBR while encoding
                        flags: readable, writable, changeable only in NULL or READY state
                        Boolean. Default: false
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.