RTSP input Test5 FPS drops after a few minutes

I’ve disabled everything except for RTSP sink output and the problem still occurs. Any idea why? Running on Jetson Xavier NX.

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=5

[source0]
enable=1
type=4
uri=rtsp://admin:123456@192.168.80.209
#num-extra-surfaces=23
gpu-id=0
#latency=4000
nvbuf-memory-type=0

[sink0]
enable=1
type=4
sync=0
qos=0
source-id=0
gpu-id=0
codec=2
iframeinterval=25
nvbuf-memory-type=0
rtsp-port=9990
#udp-port=5400
width=1080
height=720

[osd]
enable=0
gpu-id=0
border-width=1
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
clock-x-offset=800
clock-y-offset=820
clock-text-size=12
font=Arial
clock-color=1;0;0;0
nvbuf-memory-type=0
display-text=1
display-bbox=1
show-clock=0

[streammux]
gpu-id=0
live-source=1
batch-size=1
batched-push-timeout=40000
width=1280
height=720
enable-padding=1
nvbuf-memory-type=0
# attach-sys-ts-as-ntp=1

[primary-gie]
enable=0
batch-size=4
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;1;1;1
bbox-border-color3=0;1;0;1
nvbuf-memory-type=0
config-file=config_infer_primary.txt

[tracker]
enable=0
tracker-width=600
tracker-height=288
ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_klt.so
#ll-config-file required for DCF/IOU only
#ll-config-file=tracker_config.yml
#ll-config-file=iou_config.txt
gpu-id=0
#enable-batch-process applicable to DCF only
enable-batch-process=0

[tests]
file-loop=0

Hi,
Do you run DS5.0.1? If you are on r32.4.3, please upgrade to r32.4.4 and run DS5.0.1.

On single stream it works fine now but however when i increase the input stream to > 1, after awhile the CPU usage of all 6 cores become 100% based on top. Did I miss out anything in the config?

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=5

[source0]
enable=1
type=4
uri=rtsp://xxx
#num-extra-surfaces=23
gpu-id=0
#latency=4000
nvbuf-memory-type=0

[source1]
enable=1
type=4
uri=rtsp://xxx
#num-extra-surfaces=23
gpu-id=0
#latency=4000
nvbuf-memory-type=0

[source2]
enable=1
type=4
uri=rtsp://xxx
#num-extra-surfaces=23
gpu-id=0
#latency=4000
nvbuf-memory-type=0

[sink0]
enable=1
type=4
sync=0
qos=0
source-id=0
gpu-id=0
codec=2
iframeinterval=25
nvbuf-memory-type=0
rtsp-port=9990
#udp-port=5400
width=1080
height=720

[sink1]
enable=1
type=4
sync=0
qos=0
source-id=1
gpu-id=0
codec=2
iframeinterval=25
nvbuf-memory-type=0
rtsp-port=9991
udp-port=5401
width=1080
height=720

[sink2]
enable=1
type=4
sync=0
qos=0
source-id=2
gpu-id=0
codec=2
iframeinterval=25
nvbuf-memory-type=0
rtsp-port=9992
udp-port=5402
width=1080
height=720

[sink4]
enable = 1
sync = 0
type = 6
msg-conv-config = dstest5_msgconv_sample_config.txt
msg-conv-payload-type = 1
msg-broker-proto-lib = /opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_kafka_proto.so
#msg-conv-msg2p-lib = ../libs/nvmsgconv/libnvds_msgconv.so
msg-broker-conn-str = localhost;9092;psds
topic = psds

[osd]
enable=1
gpu-id=0
border-width=1
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
clock-x-offset=800
clock-y-offset=820
clock-text-size=12
font=Arial
clock-color=1;0;0;0
nvbuf-memory-type=0
display-text=1
display-bbox=1
show-clock=0

[streammux]
gpu-id=0
live-source=1
batch-size=3
batched-push-timeout=40000
width=1280
height=720
enable-padding=1
nvbuf-memory-type=0
# attach-sys-ts-as-ntp=1

[nvds-analytics]
enable = 1
config-file = analytics.txt

[primary-gie]
enable=1
batch-size=4
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;1;1;1
bbox-border-color3=0;1;0;1
nvbuf-memory-type=0
config-file=config_infer_primary.txt

[tracker]
enable=1
tracker-width=600
tracker-height=288
ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_klt.so
#ll-config-file required for DCF/IOU only
#ll-config-file=tracker_config.yml
#ll-config-file=iou_config.txt
gpu-id=0
#enable-batch-process applicable to DCF only
enable-batch-process=0

[tests]
file-loop=0

Hi,
You may set batch-size=3 in [primary-gie] since you have three sources. And disable [sink4], [nvds-analytics]. If you want to tile the sources, you can enable [tiled-display].