RTSP problem in Deepstream 5.0 GA

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson Nano Development Kit)
• DeepStream Version 5.0 GA
• JetPack Version (4.4)
• TensorRT Version

We installed the latest JetPack (on a fresh SD card) that is compatible with Deepstream 5.0 GA and followed the instructions provided in DeepStream SDK 5.0 GA Getting Started guide for Jetson.

When we have one RTSP input stream (of 1080p, 30FPS coming from a VLC runing on Jetson) and One RTSP output, with just Primary Inference + Tracker + OSD in the pipeline. This results in some kind of network storm and the response from a terminal connected via SSH on Jetson becomes very very slow. The VLC client running on a PC is unable to connect and view the RTSP output.

The application works well when used with Egl displayed on the local screen.

The above RTSP-in RTSP-out configuration had worked well with DS 5.0 DP version (and corresponding JetPack).

Has anyone seen this issues? Is there any special network configuration required for this?

This is a bottleneck and we are unable to make further analysis/progress on DS 5.0 GA.

Any help will be appreciated.

This happens when the PC running the RTSP Client (VLC) is connected on WiFI and the Jetson is connected on the Ethernet to the same router. This goes away if both are connected by Ethernet

Connecting a USB Wireless dongle to the Jetson Nano and using deepstream-app to stream on the WiFi LAN also resulted in the same issue.

Do you mean you met broadcast storm problem with Deepstream5.0 GA RTSP streaming?

Have you asked your network administrator to check the network setting first?


Yes, it appears to be broadcast storm as applications (even terminal window does not respond). Even the client where the VLC is trying to connect/receive looses network connection.

No, we have not asked the IT department to check network settings.

All network settings use default settings (on Jetson nano, Router and the PC where VLC client is running). Note: RTSP source is also a VLC running on jetson.

NOTE: Wireless connection works for all other things like ssh, FTP etc. So, there is nothing wrong with the basic WiFi connectivity. The application works well with Ethernet connection.

Can you reproduce the problem with any gstreamer app with RTSP streaming? Or only with the specific app?
What is you codes and configuration?

This is reproduced using standard deepstream-app with one RTSP stream as input and one RTSP stream as output.

What will happen if the input is local file and output is RTSP streaming?

We haven’t tried this. As we have changed the configuration back to Ethernet, we will not be able to test this for a while.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.